Bug 175765 - rename irb to ruby-irb
Summary: rename irb to ruby-irb
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-14 19:48 UTC by edgester
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.8.4-0.4.preview2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 07:25:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description edgester 2005-12-14 19:48:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7 Mnenhy/0.7.3.0

Description of problem:
Please rename the irb to ruby-irb. I just spent 0.5 days trying to figure out that I need irb which was part of ruby. I installed the ruby-* packages, but missed irb because of the name.

In addition or in lieu of this, could there be a meta-package of some sort that would install all of ruby.

This bit me royally when I was trying ton install rails (Ruby on Rails)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install ruby-*.rpm
2. get frustrated when installing rails
3. install irb*.rpm => fixed
  

Additional info:

Comment 1 Akira TAGOH 2005-12-20 07:25:30 UTC
Fixed in 1.8.4-0.4.preview2.


Note You need to log in before you can comment on or make changes to this bug.