Bug 175807 - driver for nic sis191 [sis190] for kernel 2.6.14-1.1644_FC4 hang the system on DHCP
driver for nic sis191 [sis190] for kernel 2.6.14-1.1644_FC4 hang the system o...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-15 05:03 EST by Gustavo Kuhn Andriotti
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 20:14:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gustavo Kuhn Andriotti 2005-12-15 05:03:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
If I try to use internet through my NIC, a SiS191, with the module sis190, that came with the kernel, it hangs the system every time. I have no problem loading the module, it does not hang the system. If turn off the network initialization, and do not try to bring it on after booting, the system stay stable.



Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1644_FC4

How reproducible:
Always

Steps to Reproduce:
To reproduce the error:

1. FC4 with kernel 2.6.14-1.1644_FC4 (with or without SMP support, I tested it)
2. let it goes and wait until DHCP tries to catch an IP
3. I hangs.

Counterproof:

1. Starting at single mode
2. Disable network (chkconfig --level 345 network off)
3. Reboot
4. Work normally


Actual Results:  I expect that the network driver at least does not hang the system, if it not suppose to work.

Expected Results:  If the system is unstable with that driver it should be changed by one that, if does not work, not hang the system. Or use the original one given by SiS.

Additional info:

I fixed the problem getting the SiS linux driver for SiS 190/191 (www.sis.com)

To make it work:

1. Get kernel source and install it
2. extract the source (rpmbuild -bp --target=i686 kernel-2.6.spec)
3. Override the original kernel driver with the one given by SiS
4. Compile the modules (make modules)
5. Copy to the right directory (cp and depmod -eaF /boot/System.map-2.6.14-1.1644_FC4 2.6.14-1.1644_FC4)
6. Reenable network (chkconfig --level 345 network off)
7. Reboot
8. Work like a charm.
Comment 1 John W. Linville 2005-12-15 14:35:48 EST
The fedora-netdev kernels are available here: 
 
   http://people.redhat.com/linville/kernels/fedora-netdev/ 
 
Please give those a try and let me know if the device is working...thanks! 
Comment 2 Gustavo Kuhn Andriotti 2005-12-15 18:02:14 EST
I tryed now and it works. It looks stable and looks like it has no effect on
speed or lag. Thanks!
Comment 3 Gustavo Kuhn Andriotti 2005-12-15 18:07:56 EST
I got the new kernel, 2.6.14-1.1653_FC4, and it also fixes the problem. So just
a regular kernel update to 2.6.14-1.1653_FC4 is enough.

But thanks anyway!

Note You need to log in before you can comment on or make changes to this bug.