Bug 175814 - 2.6.14-1.1653 has ``empty'' pci bus
2.6.14-1.1653 has ``empty'' pci bus
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-15 05:40 EST by QingLong
Modified: 2015-01-04 17:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 11:55:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description QingLong 2005-12-15 05:40:00 EST
Description of problem:
The kernel fails to provide pci info in /proc/.
And (as a consequence) no pci network card manages to get up
thus making network totally unavailable...

Version-Release number of selected component (if applicable):
2.6.14-1.1653 smp at PIII

How reproducible:
Just boot it and see nothing in lspci output (or in /proc/),
also try to get any real network interface up.

Steps to Reproduce:
1. lspci
2. cat /proc/bus/pci/devices
3. ifconfig -a
  
Actual results:
No info, no network interfaces.

Expected results:
Should provide actual pci info,
network interfaces should be up and running.

Additional info:
Comment 1 Dave Jones 2005-12-15 14:18:25 EST
can you try booting with acpi=off ?
Comment 2 QingLong 2005-12-16 05:49:23 EST
Yes, booting with the `acpi=off' does help.
Comment 3 Juha Luoma 2005-12-16 06:07:46 EST
Also my IBM Thinkpad 600X does not boot 1653 without acpi=off. Previous kernel
(1644) worked fine.
Comment 4 Linux ACPI Developers 2006-01-17 23:58:47 EST
Re: 600X
Different bug report, but the cause is probably that
FC is currently built with CONFIG_ACPI_BLACKLIST_YEAR=0
which enables ACPI for all systems that claim to support it.
when previously the 600X was deemed too old to run ACPI.
Somebody just donated a 600X to me and it fails for me too
so maybe we'll be able to address that one in particular.

Re: SMP PIII
Does this still fail?
If so, is "pci=noacpi" sufficient to workaround the failure?
Please attach the output of "dmesg -s64000" of a successful boot,
and also if you can capture the serial "debug" console of
a failed boot.
Comment 5 Dave Jones 2006-02-03 01:45:39 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 6 QingLong 2006-02-03 05:49:25 EST
It looks like the bug has been fixed.
The new kernel (2.6.15-1.1830_FC4) appears to handle pci info correctly.
Thanks a lot.

Note You need to log in before you can comment on or make changes to this bug.