Bug 175915 - dbus_service.c:1399: error: `DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT' undeclared (first use in this function)
dbus_service.c:1399: error: `DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT' undeclared ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcdbd (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 03:07 EST by Christophe Nowicki
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: dhcdbd-1.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-16 12:02:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christophe Nowicki 2005-12-16 03:07:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Firefox/1.0.7 (Debian package 1.0.7-1)

Description of problem:
I'am running Debian  GNU/Linux "sarge" with dbus version 0.60 (the last stable realse).
When I try to build dhcdbd, I get an compilation error :

dbus_service.c:1399: error: `DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT' undeclared (first use in this function)
dbus_service.c:1399: error: (Each undeclared identifier is reported only once
dbus_service.c:1399: error: for each function it appears in.)
dbus_service.c:1403: error: `DBUS_REQUEST_NAME_REPLY_PRIMARY_OWNER' undeclared (first use in this function)
dbus_service.c:1405: error: `DBUS_REQUEST_NAME_REPLY_EXISTS' undeclared (first use in this function)
dbus_service.c:1406: error: `DBUS_REQUEST_NAME_REPLY_IN_QUEUE' undeclared (first use in this function)
dbus_service.c:1407: error: `DBUS_REQUEST_NAME_REPLY_ALREADY_OWNER' undeclared (first use in this function)

It's because RequestName queuing behavior has changed (refer to dbus-specification) in Dbus-0.60 :

http://www.freedesktop.org/Software/dbus 




Version-Release number of selected component (if applicable):
dhcdbd-1.10

How reproducible:
Always

Steps to Reproduce:
1. install dbus-0.60
2. compile dhcpcd-1.10
3. 
  

Additional info:
Comment 1 Jason Vas Dias 2005-12-16 12:02:35 EST
Yes, this is fixed with dhcdbd-1.11 .  

dbus-0.6 removed the DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT flag - the behavior it
selected is now the default, so specifying a flag of 0 will have the same 
effect (it would have been nice if dbus-0.6 had #define'd this to 0 :-) 
You can compile dhcdbd-1.10 unchanged by adding 
  -DDBUS_NAME_FLAG_PROHIBIT_REPLACEMENT=0 

There is also the latest dhcdbd-1.11 version which removes use of this flag:

You can obtain dhcdbd from our external CVS server:

# CVS_RSH=ssh CVSROOT=':pserver:anoncvs@rhlinux.redhat.com:/usr/local/CVS' cvs login
CVS password:anoncvs
# CVS_RSH=ssh CVSROOT=':pserver:anoncvs@rhlinux.redhat.com:/usr/local/CVS' cvs
co dhcdbd

There is also BIND with D-BUS support, required for latest NetworkManager,
which also used to use  DBUS_NAME_FLAG_PROHIBIT_REPLACEMENT - versions 
bind-9.3.1-26 and bind-9.3.2rc1-1 no longer do so.

Note You need to log in before you can comment on or make changes to this bug.