Bug 175941 - kernel-devel removes inintab (.rpmsave) and initscripts doesn't replace it during update
kernel-devel removes inintab (.rpmsave) and initscripts doesn't replace it du...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 11:28 EST by Peter Quiring
Modified: 2014-01-21 17:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 06:24:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Quiring 2005-12-16 11:28:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051211 Fedora/1.5-1.1 Firefox/1.5

Description of problem:
When running 'yum update' today, I noticed that during kernel-devel package update it renamed inittab and adjtime to .rpmsave files.  Then the initscripts was removed and then updated but these files were not put back.  Not sure what would happen if I rebooted but I think I know what would happen (boot failure).

Note : There is currently a break in yum so I did a partial update (yum update "i*" "k*" "s*"):

Here is a dump of yum output:

Running Transaction
  Updating  : system-config-date           ####################### [ 1/12]
  Installing: kernel-devel                 ####################### [ 2/12]
warning: /etc/inittab saved as /etc/inittab.rpmsave
warning: /etc/adjtime saved as /etc/adjtime.rpmsave
  Removing  : initscripts                  ####################### [ 3/12]
  Updating  : selinux-policy-targeted      ####################### [ 4/12]
  Updating  : sysklogd                     ####################### [ 5/12]
  Updating  : initscripts                  ####################### [ 6/12]
fgrep: /etc/inittab: No such file or directory
  Installing: kernel                       ####################### [ 7/12]
  Cleanup   : kernel                       ####################### [ 8/12]
  Cleanup   : selinux-policy-targeted      ####################### [ 9/12]
  Cleanup   : sysklogd                     ####################### [10/12]
  Cleanup   : kernel-devel                 ####################### [11/12]
  Cleanup   : system-config-date           ####################### [12/12]

Removed: kernel.i686 0:2.6.14-1.1765_FC5 kernel-devel.i686 0:2.6.14-1.1765_FC5
Installed: kernel.i686 0:2.6.14-1.1767_FC5 kernel-devel.i686 0:2.6.14-1.1767_FC5
Updated: initscripts.i386 0:8.19-1 selinux-policy-targeted.noarch 0:2.1.6-4 sysklogd.i386 0:1.4.1-34 system-config-date.noarch 0:1.7.99.11-1
Complete!


Version-Release number of selected component (if applicable):
initscripts-8.19-1

How reproducible:
Didn't try

Steps to Reproduce:
1.yum update
2.
3.
  

Actual Results:  /etc/inittab and adjtime renamed to .rpmsave and no new files to replace them.

Expected Results:  Create new files or leave old ones there.

Additional info:
Comment 1 Bill Nottingham 2005-12-17 02:29:34 EST
This is a yum issue - it should not be running remove before install.
Comment 2 Seth Vidal 2005-12-17 08:37:21 EST
Yum is using rpm's ordering mechanism, not its own.


You'll note in the transaction output it lists update and installs first and
cleanups last.

cleanups == removal.
Comment 3 Seth Vidal 2005-12-17 12:51:23 EST
whoops - I missed the removal of initscripts in the output.

Still - yum is just using ts.order() for the ordering.

Paul? Anything change in transaction ordering?

Comment 4 Paul Nasrat 2005-12-18 07:05:46 EST
No I haven't changed yum's ordering code.
Comment 5 Rahul Sundaram 2006-02-20 06:24:42 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Note You need to log in before you can comment on or make changes to this bug.