Bug 175942 - kernel-2.6.14-1.1767_FC4 does not build on FC4
kernel-2.6.14-1.1767_FC4 does not build on FC4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 11:29 EST by Andrew Duggan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.14-1.1768_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-17 10:02:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Duggan 2005-12-16 11:29:30 EST
Description of problem:
simple rebuild from source rpm failes

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1767_FC4.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. d/l src.rpm from people.redhat.com/davej/kernels/Fedora/FC4/SRPMS.kernel
2. rpm -i kernel-2.6.14-1.1767_FC4.src.rpm
3. rpmbuild -bb --target i686 ~/rpmbuild/SPECS/kernel-2.6.spec
  
Actual results:
CONFIG_PM_LEGACY
CONFIG_RFD_FTL
CONFIG_MTD_ONENAND
CONFIG_BLK_DEV_CS5535
CONFIG_ISCSI_TCP
CONFIG_ATM_DUMMY
CONFIG_PPP_MPPE
CONFIG_INPUT_WISTRON_BTNS
CONFIG_CARDMAN_4000
CONFIG_CARDMAN_4040
CONFIG_VIDEO_BT848_DVB
CONFIG_VIDEO_SAA7134_DVB_ALL_FRONTENDS
CONFIG_VIDEO_CX88_DVB_ALL_FRONTENDS
CONFIG_VIDEO_EM28XX
CONFIG_VIDEO_AUDIO_DECODER
CONFIG_VIDEO_DECODER
CONFIG_FRAMEBUFFER_CONSOLE_ROTATION
CONFIG_USB_LIBUSUAL
CONFIG_USB_SERIAL_ANYDATA
CONFIG_INFINIBAND_SRP
CONFIG_JFFS2_SUMMARY
CONFIG_SQUASHFS
make[1]: *** [nonint_oldconfig] Error 22


Expected results:
successful build

Additional info:

No customization where done. 

Adding those config items to kernel-2.6.14-i?86*.config allows for a clean build
 at least it gets past the make oldconfig stage.  (still building) I greped the
list against /boot/config-2.6.14-1.1767_FC5 from a rawhide machine.  Not sure if
the options would be the same since the config of FC4 and FC5 kernels differ. 

**** FWIW  udev-071 has been running very well for me on FC4. for a month now on
two machines.  Both run selinux targeted policy enforcing  and there is *no*
slow down during configuring hardware during boot.
Comment 1 Andrew Duggan 2005-12-29 23:53:50 EST
FWIW in kernel-2.6.14-1.1778_FC4.src.rpm

CONFIG_VIDEO_SAA7134_ALSA=m
needs to be added to the kernel-2.6.14-1.i686-kdump.config
on i686.

Note You need to log in before you can comment on or make changes to this bug.