Bug 175950 - rekall crashes when trying to add a new database
rekall crashes when trying to add a new database
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rekall (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 12:24 EST by Craig Goodyear
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 13:32:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace following rekall crash (6.29 KB, text/plain)
2005-12-16 12:28 EST, Craig Goodyear
no flags Details

  None (edit)
Description Craig Goodyear 2005-12-16 12:24:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I have installed rekall 2.2.4-8.fc4 from extras.  The following components were insatlled: 

rekall-common
rekall
rekall-docs
rekall-mysql
rekall-devel
rekall-python

I am using kernel 2.6.14-1.1653_FC4.

I can start rekall, but when trying to add a new database, rekall will crash.


Version-Release number of selected component (if applicable):
rekall 2.2.4-8.fc4

How reproducible:
Always

Steps to Reproduce:
1. select File -> New Database from menu
2. select Next on wizard that appears
3. enter directory and database name in Choose Database File dialog
4. click the Next button
5. click the Next button on Where to Store Forms dialog

  

Actual Results:  rekall crashes

Expected Results:  new database file should be created

Additional info:
Comment 1 Craig Goodyear 2005-12-16 12:28:53 EST
Created attachment 122330 [details]
backtrace following rekall crash
Comment 2 Tom "spot" Callaway 2005-12-16 12:29:17 EST
What type of database were you using?
Comment 3 Craig Goodyear 2005-12-16 12:33:18 EST
(In reply to comment #2)
> What type of database were you using?

The crash occurs prior to reaching a dialog to specify the external database or
database type.  It occurs while trying to create the .rkl file.
Comment 4 Tom "spot" Callaway 2005-12-16 12:54:56 EST
OK, I see. I cannot reproduce this crash on my laptop (FC5), let me try to find
an FC4 machine to test with.
Comment 5 Tom "spot" Callaway 2006-04-07 10:29:54 EDT
I can't reproduce this in 2.4.0. Please try to update to the 2.4.0 packages
(making sure the 2.2.* packages are missing) and test this.
Comment 6 Craig Goodyear 2006-04-07 12:54:20 EDT
Updating to version 2.4.0 has fixed the problem.
Comment 7 Tom "spot" Callaway 2006-04-07 13:32:44 EDT
Closing.

Note You need to log in before you can comment on or make changes to this bug.