Bug 175965 - early kernel panic
early kernel panic
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 14:22 EST by Gabriel Ramirez
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-27 17:45:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first image de eigth showing the screen (53.27 KB, image/jpeg)
2005-12-16 14:22 EST, Gabriel Ramirez
no flags Details
second image de eigth showing the screen of kernel booting (45.34 KB, image/jpeg)
2005-12-16 14:24 EST, Gabriel Ramirez
no flags Details
third image de eigth showing the screen of kernel booting (59.70 KB, image/jpeg)
2005-12-16 14:35 EST, Gabriel Ramirez
no flags Details
four image de eigth showing the screen of kernel booting (58.59 KB, image/jpeg)
2005-12-16 14:35 EST, Gabriel Ramirez
no flags Details
five image de eigth showing the screen of kernel booting (53.42 KB, image/jpeg)
2005-12-16 17:03 EST, Gabriel Ramirez
no flags Details
six image de eight showing the screen of kernel booting (55.04 KB, image/jpeg)
2005-12-16 17:04 EST, Gabriel Ramirez
no flags Details
seven image de eight showing the screen of kernel booting (54.26 KB, image/jpeg)
2005-12-16 17:05 EST, Gabriel Ramirez
no flags Details
eight image de eight showing the screen of kernel booting (61.06 KB, image/jpeg)
2005-12-16 17:05 EST, Gabriel Ramirez
no flags Details
before the pause of kernel panic version 1770 (311.02 KB, image/jpeg)
2005-12-17 14:43 EST, Gabriel Ramirez
no flags Details
after the pause of kernel panic version 1770 (341.90 KB, image/jpeg)
2005-12-17 14:45 EST, Gabriel Ramirez
no flags Details
oops from kernel 2.6.14 1770smp with vga=1 (1.96 KB, text/plain)
2005-12-20 13:20 EST, Gabriel Ramirez
no flags Details
/var/log/messages from kernel 1696smp only the boot and shutdown parts (32.70 KB, text/plain)
2005-12-20 23:30 EST, Gabriel Ramirez
no flags Details
/var/log/messages from kernel 1776smp only the boot and shutdown parts (33.41 KB, text/plain)
2005-12-20 23:32 EST, Gabriel Ramirez
no flags Details
tar file with dmesg and messages logs from kernel 1783smp one pair witrh vga=1 and another with vga=791 in both cases the kernel functions well (19.14 KB, application/octet-stream)
2005-12-26 20:41 EST, Gabriel Ramirez
no flags Details

  None (edit)
Description Gabriel Ramirez 2005-12-16 14:22:17 EST
Description of problem:
I have a thinkpad T43 with Pentium(R) M processor 1.86GHz and I installed Fedora
Core 5 test1 and I can boot with kernel 2.6.14-1.1696_FC5smp with the option
mem=nopentium but with kernels 2.6.14-1.1760_FC5smp 2.6.14-1.1765_FC5smp and
2.6.14-1.1767_FC5smp I tried the 2.6.14-1.1765_FC5 witrh similar results and
some days ago  I was able to boot with a kernel version 1740 or something


Version-Release number of selected component (if applicable):
2.6.14-1.1760_FC5smp 2.6.14-1.1765_FC5smp and 2.6.14-1.1767_FC5smp I tried the
2.6.14-1.1765_FC5

How reproducible:

always

Steps to Reproduce:
1. boot any of kernel above
2.
3.
  
Actual results:

early kernel panic


Expected results:

normal boot
Additional info:
Comment 1 Gabriel Ramirez 2005-12-16 14:22:18 EST
Created attachment 122342 [details]
first image de eigth showing the screen
Comment 2 Gabriel Ramirez 2005-12-16 14:24:01 EST
Created attachment 122343 [details]
second  image de eigth showing the screen of kernel booting
Comment 3 Gabriel Ramirez 2005-12-16 14:35:07 EST
Created attachment 122346 [details]
third image de eigth showing the screen of kernel booting
Comment 4 Gabriel Ramirez 2005-12-16 14:35:45 EST
Created attachment 122348 [details]
four image de eigth showing the screen of kernel booting
Comment 5 Gabriel Ramirez 2005-12-16 17:03:48 EST
Created attachment 122354 [details]
five  image de eigth showing the screen of kernel booting
Comment 6 Gabriel Ramirez 2005-12-16 17:04:29 EST
Created attachment 122355 [details]
six image de eight showing the screen of kernel booting
Comment 7 Gabriel Ramirez 2005-12-16 17:05:05 EST
Created attachment 122356 [details]
seven image de eight showing the screen of kernel booting
Comment 8 Gabriel Ramirez 2005-12-16 17:05:45 EST
Created attachment 122357 [details]
eight image de eight showing the screen of kernel booting
Comment 9 Dave Jones 2005-12-17 02:08:40 EST
with the latest update, it should pause for 2 minutes after an oops occurs, can
you boot that, and try to get a clearer screenshot ?

It'd also help if you booted with vga=791 (if your laptop supports that mode)
which gets more lines of text onscreen.

We only one shot of that last screen when it hangs.

thanks.
Comment 10 Gabriel Ramirez 2005-12-17 14:42:11 EST
I tried with vga=791 and kernel 1770 and the screen is all black, I tried with
the original kernel of fc5test1 and works showing more lines, anyway I will
upload the screen shot in two parts before the pause and after it of kernel
1770. thanks
Comment 11 Gabriel Ramirez 2005-12-17 14:43:28 EST
Created attachment 122367 [details]
before the pause of kernel panic version 1770
Comment 12 Gabriel Ramirez 2005-12-17 14:45:22 EST
Created attachment 122368 [details]
after the pause of kernel panic version 1770

please let me know if the photos are ok.

thanks
Comment 13 Gabriel Ramirez 2005-12-17 15:24:47 EST
I forgot to mention the screenshots are from kernel 1770smp 
Comment 14 Dave Jones 2005-12-17 22:58:21 EST
try with 'vga=1'.  it seems 791 is too high for the lcd, but '1' is just 80x50,
which it should be capable of.
Comment 15 Gabriel Ramirez 2005-12-19 11:37:24 EST
(In reply to comment #14)
> try with 'vga=1'.  it seems 791 is too high for the lcd, but '1' is just 80x50,
> which it should be capable of.

well with the original kernel of fc5test1 release 1696 vga=791 works fine, well
I see a little penguin and more lines I don't if that is 80x50 or more , but
kernel 1770smp show a black screen only with vga=1
Comment 16 Gabriel Ramirez 2005-12-19 22:26:21 EST
(In reply to comment #15)
> (In reply to comment #14)
> > try with 'vga=1'.  it seems 791 is too high for the lcd, but '1' is just 80x50,
> > which it should be capable of.
> 
> well with the original kernel of fc5test1 release 1696 vga=791 works fine, well
> I see a little penguin and more lines I don't if that is 80x50 or more , but
> kernel 1770smp show a black screen only with vga=1

sorry I take too much coffe and the last line  is incorrect  that will be 
kernel 1770smp show a black screen only with vga=791

I dont try kernel 1770smp with vga=1, because I don't have the camera this day :(
Comment 17 Gabriel Ramirez 2005-12-20 13:20:34 EST
Created attachment 122458 [details]
oops from kernel 2.6.14 1770smp with vga=1

here is the screen from kernel 2.6.14 1770smp, I have to type in notepad from
windows so it have CR\LF.

kernel 1696 can boot normal and with vga=791 or vga=1
kernel 1770 is unable to boot but show the oops with vga=1 but with vga the
screen is black
please let me know if you need any aditional info.


thanks
Comment 18 Gabriel Ramirez 2005-12-20 23:26:38 EST
I dowonloaded kernel 1776smp and that kernel boots but it don't find or don't
initialize properly some devices notably the broadcom network adapter I will
attach 2 log files specifically the /var/log/messages one from kernel 1696smp
and another from 1776smp

Gabriel
Comment 19 Gabriel Ramirez 2005-12-20 23:30:43 EST
Created attachment 122477 [details]
/var/log/messages from kernel 1696smp only the boot and shutdown parts
Comment 20 Gabriel Ramirez 2005-12-20 23:32:07 EST
Created attachment 122478 [details]
/var/log/messages from kernel 1776smp only the boot and shutdown parts
Comment 21 Dave Jones 2005-12-23 14:07:06 EST
does todays kernel do any better ? It reversed some bad acpi patches..
Comment 22 Gabriel Ramirez 2005-12-26 20:37:17 EST
Hi, 

I tested kernel 178smp , and yes it works with vga=1 or vga=791 too, all I can
test woorks fine, but it shows a warning in the eth1 that is a intel ip2200
wireless, but I don't have any wireless network to test if the warning is
harmless or not I will attach the dmesg and messages logs from kernel 1783smp
with options vga=1 and vga=791.

the warning is athe end  of the messages logs is somehing about eth1. reports
NET-BUSY but will  be report netfull or something for the style, 

but i consider this bug fixed many many thanks
Comment 23 Gabriel Ramirez 2005-12-26 20:41:00 EST
Created attachment 122590 [details]
tar file with dmesg and messages logs from kernel 1783smp one pair witrh vga=1 and another with vga=791 in both cases the kernel functions well
Comment 24 Dave Jones 2005-12-27 17:45:28 EST
the warning is harmless, (especially as you don't have a wireless network).  As
the early oops is gone, I'll close this bug.

Thanks for the debugging.

Note You need to log in before you can comment on or make changes to this bug.