Bug 175993 - Synaptics touchpad not recognized with kernel 2.6.14-1.1767_FC4smp
Synaptics touchpad not recognized with kernel 2.6.14-1.1767_FC4smp
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 176011 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 18:45 EST by Brian Gaynor
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 05:10:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Good /proc/bus/input/devices (458 bytes, text/plain)
2005-12-22 13:55 EST, Brian Gaynor
no flags Details
Bad /proc/bus/input/devices (509 bytes, text/plain)
2005-12-22 13:56 EST, Brian Gaynor
no flags Details
Good dmesg (19.08 KB, text/plain)
2005-12-22 13:57 EST, Brian Gaynor
no flags Details
Bad dmesg (19.83 KB, text/plain)
2005-12-22 13:58 EST, Brian Gaynor
no flags Details
Good / bad xorg.conf (3.14 KB, text/plain)
2005-12-22 17:50 EST, Brian Gaynor
no flags Details
Good Xorg.0.log (34.78 KB, text/plain)
2005-12-22 17:51 EST, Brian Gaynor
no flags Details
Bad Xorg.0.log (34.75 KB, text/plain)
2005-12-22 17:51 EST, Brian Gaynor
no flags Details

  None (edit)
Description Brian Gaynor 2005-12-16 18:45:40 EST
Description of problem:
Synaptics touchpad on a Dell Inspiron 5160 is not recognized when booting with
kernel 2.6.14-1.1767_FC4smp (Dave Jones 2.6.15rc). Earlier kernels have worked
just fine.

Version-Release number of selected component (if applicable):
synaptics-0.14.0-2
kernel 2.6.14-1.1767_FC4smp

How reproducible:
Always

Steps to Reproduce:
1. Install test kernel 2.6.14-1.1767_FC4smp
2. Boot into X
3.
  
Actual results:
Synaptics touchpad not recognized, ends up configured as PS/2 mouse.

Expected results:
Synaptics Touchpad should be detected correctly and configured.

Additional info:

[brian@canis ~]$ uname -a
Linux canis 2.6.14-1.1767_FC4smp #1 SMP Fri Dec 16 01:05:02 EST 2005 i686 i686
i386 GNU/Linux

Let me know if I can provide additional info, logs, etc.
Comment 1 Rodd Clarkson 2005-12-18 19:34:11 EST
Not working for me on 'Linux localhost.localdomain 2.6.14-1.1769_FC4 #1 Sat Dec
17 20:46:33 EST 2005 i686 i686 i386 GNU/Linux'
Comment 2 Paul Nasrat 2005-12-22 06:35:46 EST
Please attach dmesg output and the output of cat /proc/bus/input/devices for
working and non-working kernels.
.
Comment 3 Brian Gaynor 2005-12-22 13:55:42 EST
Created attachment 122531 [details]
Good /proc/bus/input/devices
Comment 4 Brian Gaynor 2005-12-22 13:56:48 EST
Created attachment 122532 [details]
Bad /proc/bus/input/devices
Comment 5 Brian Gaynor 2005-12-22 13:57:22 EST
Created attachment 122533 [details]
Good dmesg
Comment 6 Brian Gaynor 2005-12-22 13:58:01 EST
Created attachment 122534 [details]
Bad dmesg
Comment 7 Paul Nasrat 2005-12-22 17:02:22 EST
Those all look sane what does your xorg.conf look like and the Xorg.0.log for
good/bad case.
Comment 8 Brian Gaynor 2005-12-22 17:50:08 EST
Created attachment 122543 [details]
Good / bad xorg.conf

I'm not making any changes to xorg.conf when switching kernels.
Comment 9 Brian Gaynor 2005-12-22 17:51:04 EST
Created attachment 122544 [details]
Good Xorg.0.log
Comment 10 Brian Gaynor 2005-12-22 17:51:40 EST
Created attachment 122545 [details]
Bad Xorg.0.log
Comment 11 Paul Nasrat 2005-12-23 03:55:58 EST
auto-dev seems to be failing:

(II) Synaptics touchpad driver version 0.14.0
(--) Synaptics auto-dev sets device to /dev/input/event1

(II) Synaptics touchpad driver version 0.14.0
Synaptics no synaptics event device found (checked 1 nodes)

Both /proc/bus/input/devices list event1 as a handler for the synaptics touchpad
does /dev/input/event1 exist under both kernels?
Comment 12 Brian Gaynor 2005-12-23 12:35:08 EST
Paul -

On the working (released kernel) I have a /dev/input/event1 (as well as an
event0, mice, and mouse0). On Dave's test kernel (1771), I only see a
/dev/input/mice, NO event1. 

This machine is running up-to-date FC4, with only Dave's kernel-smp and
kernel-smp-devel installed for testing (no other testing software). 
Comment 13 Brian Gaynor 2005-12-23 12:40:19 EST
On this machine selinux is running in Targeted/Permissive mode.
Comment 14 Dave Jones 2005-12-23 22:57:51 EST
2.6.15 needs a udev update. that'll make this work again.
Comment 15 Dave Jones 2005-12-23 23:01:03 EST
*** Bug 176011 has been marked as a duplicate of this bug. ***
Comment 16 Niki W. Waibel 2006-01-11 17:00:13 EST
same problem using self-compiled linux-2.6.15:
===
$ ls -l /dev/input/
total 0
crw-rw----  1 root root 13, 63 2006-01-11 21:47 mice
===
-> no eventX entries for the synaptics touchpad (on a ibm thinkad t40) anymore ...

===
$ grep udevinfo linux-2.6.15/Documentation/Changes 
o  udev                   071                     # udevinfo -V
===

so, what about udev-071 for fc4?
if the kernel interfaces change, the userland-tools have to change as well!

on http://www.kernel.org/pub/linux/utils/kernel/hotplug/ there is version 080
available already...
Comment 17 Paul Nasrat 2006-01-24 16:19:24 EST
udev update required for fc4 by the looks
Comment 18 Harald Hoyer 2006-01-26 08:16:27 EST
does it work with udev-071 in the test update?
Comment 19 Niki W. Waibel 2006-01-30 19:28:55 EST
hmmm ... udev-078-8 from the development repos needs GLIBC_2.4
(glibc-2.3.90-30), and i am not sure if i want to upgrade the glibc already...
Comment 20 Harald Hoyer 2006-01-31 04:32:17 EST
udev-071 for FC-4 can be found here:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/4/
Comment 21 kmike 2006-01-31 11:00:51 EST
Entries for Synaptics appear again in /dev/input/ with udev-071 and kernel
2.6.15-1 from FC4-testing.
Comment 22 Niki W. Waibel 2006-02-10 19:16:44 EST
things are fine now with self compiled 2.6.15.x kernels...
Comment 23 Rodd Clarkson 2006-02-12 16:11:06 EST
This is working well with 2.6.15-1.1830_FC4

Note You need to log in before you can comment on or make changes to this bug.