Bug 176011 - 2.6.15rc kernel package for FC4 prevents X from starting.
2.6.15rc kernel package for FC4 prevents X from starting.
Status: CLOSED DUPLICATE of bug 175993
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-17 10:08 EST by Fabio Comolli
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-23 23:00:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fabio Comolli 2005-12-17 10:08:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
X does not start not being able to find pointing device. The problem is caused by /dev/input missing some links.

With a custom 2.6.15-rc5 kernel with evdev compiled as module /dev/input looks like:

fcomolli@tycho ~]$ ls -l /dev/input/
total 0
crw-rw----  1 root root 13, 64 Dec 17  2005 event0
crw-rw----  1 root root 13, 65 Dec 17  2005 event1
crw-rw----  1 root root 13, 63 Dec 17  2005 mice

With 2.6.14-1.1768_FC4 there is only the "mice" entry. The touchpad is /dev/input/event0:

fcomolli@tycho ~]$ grep "/dev/input" /var/log/Xorg.0.log
(--) Mouse2 auto-dev sets device to /dev/input/event0
(**) Option "Device" "/dev/input/event0"



Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1768_FC4     udev-058-1.0.FC4.1

How reproducible:
Always

Steps to Reproduce:
1. Just boot the kernel
2.
3.
  

Actual Results:  X does not start. Xorg.0.log says:

(II) Synaptics touchpad driver version 0.14.0
Mouse2 no synaptics event device found (checked 1 nodes)

Expected Results:  X starts. Xorg.0.log says:

(II) Synaptics touchpad driver version 0.14.0
(--) Mouse2 auto-dev sets device to /dev/input/event0
(**) Option "Device" "/dev/input/event0"

Additional info:
Comment 1 Fabio Comolli 2005-12-17 10:35:11 EST
Maybe (probably?) related to 175993
Comment 2 Dave Jones 2005-12-23 23:00:54 EST
yep. same thign. needs a newer udev


*** This bug has been marked as a duplicate of 175993 ***

Note You need to log in before you can comment on or make changes to this bug.