Bug 176042 - Perl debugger won't start
Perl debugger won't start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-18 02:24 EST by Peter Gordon
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: perl-5.8.5-24.FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 12:52:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gordon 2005-12-18 02:24:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
When starting a program with the perl debugger, the program crashes.
This is because of an error in file /usr/lib/perl5/5.8.5/perl5db.pl

On line 5814 of the file there is a line that reads 
my $rv = $ENV{PERLDB_NOTTY} || ( $ENV{HOME} ? $ENV{HOME} : /tmp ) ."/perldbtty$$";

The /tmp should be in quotes

my $rv = $ENV{PERLDB_NOTTY} || ( $ENV{HOME} ? $ENV{HOME} : "/tmp" ) ."/perldbtty$$";

That fixes the problem





Version-Release number of selected component (if applicable):
perl-5.8.5-22.FC3

How reproducible:
Always

Steps to Reproduce:
perl -d anyprogram


Additional info:
Comment 1 Paul Howarth 2005-12-18 05:46:18 EST
Looks like a duplicate of Bug 175953, which should be fixed by the recent
perl-5.8.5-24.FC3 errata update.
Comment 2 Jason Vas Dias 2005-12-19 12:52:45 EST
Yes, apologies - this typo was fixed with the perl-5.8.5-24.FC3 errata update .

Note You need to log in before you can comment on or make changes to this bug.