Bug 176064 - KDE no longer does SVG image format previews in konqueror
KDE no longer does SVG image format previews in konqueror
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
http://straw.sh.nu/kde/kde-3.5.0-no-S...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-18 17:39 EST by Niko Mirthes
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 06:35:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niko Mirthes 2005-12-18 17:39:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
KDE should be generating thumbnails when browsing a folder containing files in the SVG image format. This worked with the previous KDE 3.4.2 packages and it works with my personal build. There should also be a ksvg plugin that allows viewing SVG's embedded in konqueror. Both features are missing with the recent release of KDE 3.5.0 to updates-released. Looking over the relevant patches and .specs (kdelibs and kdegraphics) I can't see where this has been intentionally disabled. Can anyone shed any light on this?


Version-Release number of selected component (if applicable):
kdelibs-3.5.0-0.1.fc4

How reproducible:
Always

Steps to Reproduce:
1. Browse to a directory conatining SVG images with konqueror
2. On the menubar, go to View -> Preview and look for an entry for the SVG format
3. Note the entry is missing


Actual Results:  No previews are shown, nor is the ksvg plugin available when looking at the svg mimetype settings found on konqueror's File Associations page.

Expected Results:  Konqueror should have the SVG Preview option available as well as the ksvg plugin.

Additional info:
Comment 1 Patrick Barnes 2005-12-19 17:04:56 EST
This problem is also present in Rawhide.  Instead of appropriate thumbnails, a
thumbnail of the plaintext XML is shown.
Comment 2 Bill Crawford 2005-12-21 12:08:16 EST
This is a problem when adding / selecting desktop backgrounds too (although the
desktop does display correctly).
Comment 3 Niko Mirthes 2005-12-22 20:28:23 EST
I finally realized why this is happening. Seems ksvg (kdegraphics) requires
lcms/lcms-devel, which is available from extras. Saying ./configure in
kdegraphics without lcms-devel installed results in the following message:

Some of the libraries required for KSVG are missing or too old,
therefore KSVG will not be compiled.

If you want to compile KSVG you should install:
* lcms 1.09 or newer (http://www.littlecms.com/)

I've rebuilt kdegraphics with lcms-devel installed and svg previews and the ksvg
konqueror plugin are both available again.

Can packages from base require packages from extras? I've noticed koffice-krita
and koffice-suite both complain if i try to remove lcms.
Comment 4 Bill Crawford 2005-12-23 16:35:31 EST
lcms shouldn't be in Extras, then.
Comment 5 Niko Mirthes 2006-01-09 23:54:31 EST
Can anyone comment on the likelihood of bringing lcms into base? 
Comment 6 Patrick Barnes 2006-01-10 17:04:48 EST
lcms has been pulled into Core for Mono.
Comment 7 Niko Mirthes 2006-01-19 12:47:49 EST
That's great news. Is there a process for moving something from extras to 
core/base? I'd like to see this happen for FC4 as well. 
Comment 8 Ngo Than 2006-02-07 06:35:10 EST
lcms has been pulled into Core now, adn this problem has been fixed in rawhide.

For FC4, it cannot be built with ksvg support because of lacking lcms library.

Note You need to log in before you can comment on or make changes to this bug.