Bug 176065 - rhythmbox crashes when changing songs
rhythmbox crashes when changing songs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-18 18:27 EST by Ian Burrell
Modified: 2013-03-13 00:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 16:21:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Burrell 2005-12-18 18:27:31 EST
Description of problem:

rhythmbox crashes when switching to Ogg files when the window is open.

Version-Release number of selected component (if applicable):

rhythmbox-0.9.2-3.1.x86_64

Steps to Reproduce:
1. Select album with Ogg files
2. Hit Play
3. Hit Next
4. Crash

OR 

1. Select album
2. Hit Play
3. Leave window open
4. Crash when switch to next song
  
Additional info:

To stderr it outputs:

** (rhythmbox:4980): WARNING **: nautilus_burn_drive_free is deprecated please
use nautilus_burn_drive_unref() instead

(rhythmbox:4980): GLib-GObject-WARNING **: gvalue.c:89: cannot initialize GValue
with type `gdouble', the value has already been initialized as `(null)'

(rhythmbox:4980): GLib-GObject-CRITICAL **: g_value_set_double: assertion
`G_VALUE_HOLDS_DOUBLE (value)' failed

(rhythmbox:4980): GLib-GObject-CRITICAL **: g_param_value_validate: assertion
`G_IS_VALUE (value)' failed

(rhythmbox:4980): GLib-GObject-CRITICAL **: g_object_set_property: assertion
`G_IS_VALUE (value)' failed
(rhythmbox:4980): GLib-GObject-CRITICAL **: g_value_unset: assertion `G_IS_VALUE
(value)' failed

(rhythmbox:4980): GLib-GObject-WARNING **: gvalue.c:89: cannot initialize GValue
with type `gdouble', the value has already been initialized as `(null)'

(rhythmbox:4980): GLib-GObject-CRITICAL **: g_value_set_double: assertion
`G_VALUE_HOLDS_DOUBLE (value)' failed

(rhythmbox:4980): GLib-GObject-CRITICAL **: g_param_value_validate: assertion
`PSPEC_APPLIES_TO_VALUE (pspec, value)' failed
Segmentation fault (core dumped)
Comment 1 Ian Burrell 2005-12-18 18:28:27 EST
The stack trace is:

(gdb)     thread apply all bt

Thread 5 (process 4982):
#0  0x0000003304e08c57 in ?? () from /lib64/libpthread.so.0
#1  0x00000033082020e0 in g_cond_timed_wait_posix_impl (cond=Variable "cond" is
not available.
) at gthread-posix.c:229
#2  0x0000003305c1040c in g_async_queue_pop_intern_unlocked (queue=0x83ca60,
try=Variable "try" is not available.
) at gasyncqueue.c:338
#3  0x0000003305c104fc in IA__g_async_queue_timed_pop (queue=0x83ca60,
end_time=0x40a00160) at gasyncqueue.c:464
#4  0x0000000000453d7d in action_thread_main (db=0x6e9ba0) at rhythmdb.c:1642
#5  0x0000003305c3e5ef in g_thread_create_proxy (data=0x8403a0) at gthread.c:582
#6  0x0000003304e0684c in start_thread (arg=Variable "arg" is not available.
) at pthread_create.c:261
#7  0x00000033049cbecd in ?? () from /lib64/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 4 (process 4983):
#0  0x00000033049c2a90 in *__GI___poll (fds=0x7e3690, nfds=9, timeout=-1) at
../sysdeps/unix/sysv/linux/poll.c:86
#1  0x0000003305c276d5 in g_main_context_iterate (context=0x7e1dd0, block=1,
dispatch=1, self=Variable "self" is not available.
) at gmain.c:2846
#2  0x0000003305c27c10 in IA__g_main_loop_run (loop=0x83f0d0) at gmain.c:2748
#3  0x0000003309e42ed3 in link_io_thread_fn (data=Variable "data" is not available.
) at linc.c:394
#4  0x0000003305c3e5ef in g_thread_create_proxy (data=0x7d4c70) at gthread.c:582
#5  0x0000003304e0684c in start_thread (arg=Variable "arg" is not available.
) at pthread_create.c:261
#6  0x00000033049cbecd in ?? () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 3 (process 4988):
#0  0x0000003304e08a66 in ?? () from /lib64/libpthread.so.0
#1  0x000000330de49173 in ?? ()
#2  0x000000330de73708 in ?? ()
#3  0x0000000000bda510 in ?? ()
#4  0x0000000000aa5c60 in ?? ()
#5  0x0000003300000107 in ?? ()
#6  0x0000003300000000 in ?? ()
#7  0x0000000000000000 in ?? ()

Thread 2 (process 4993):
#0  0x0000003304e0b1c9 in ?? () from /lib64/libpthread.so.0
#1  0x0000000000000000 in ?? ()

Thread 1 (process 4980):
#0  0x0000003306a20c6f in IA__g_type_parent (type=3096250513620992) at gtype.c:2645
#1  0x0000003306a29950 in transform_func_lookup (src_type=9147472, dest_type=60)
at gvalue.c:258
#2  0x0000003306a2a0b5 in IA__g_value_transform (src_value=0x7fffffa2cef0,
dest_value=0x7fffffa2ce50) at gvalue.c:347
#3  0x0000003306a1047b in IA__g_object_set_property (object=0xeea7a0,
property_name=Variable "property_name" is not available.
) at gobject.c:675
#4  0x0000000000465924 in rb_player_set_replaygain (mp=0x89b0e0,
track_gain=-4.4199999999999999, track_peak=Variable "track_peak" is not available.
)
    at rb-player-gst.c:791
#5  0x000000000042ce19 in rb_shell_player_set_playing_entry (player=0x7b6990,
entry=0xd13aa0, error=0x7fffffa2cf98)
    at rb-shell-player.c:1100
#6  0x000000000042d415 in rb_shell_player_do_next (player=0x7b6990,
error=0x7fffffa2cf98) at rb-shell-player.c:1281
#7  0x000000000042d533 in rb_shell_player_next_button_cb (button=Variable
"button" is not available.
) at rb-shell-player.c:1337
#8  0x0000003306a0ace8 in IA__g_closure_invoke (closure=0x6db520,
return_value=0x0, n_param_values=1,
    param_values=0x7fffffa2d240, invocation_hint=0x7fffffa2d0f0) at gclosure.c:490
#9  0x0000003306a1a1da in signal_emit_unlocked_R (node=0x7e98d0, detail=0,
instance=0x87d000, emission_return=0x0,
    instance_and_params=0x7fffffa2d240) at gsignal.c:2449
---Type <return> to continue, or q <return> to quit---
#10 0x0000003306a1b3d5 in IA__g_signal_emit_valist (instance=0x87d000,
signal_id=Variable "signal_id" is not available.
) at gsignal.c:2208
#11 0x0000003306a1b68d in IA__g_signal_emit (instance=Variable "instance" is not
available.
) at gsignal.c:2252
#12 0x0000003891b685be in ?? ()
#13 0x0000003304e07fd0 in ?? () at pthread_mutex_unlock.c:68 from
/lib64/libpthread.so.0
#14 0x0000003306a0ace8 in IA__g_closure_invoke (closure=0x7ea2e0,
return_value=0x0, n_param_values=1,
    param_values=0x7fffffa2d800, invocation_hint=0x7fffffa2d6b0) at gclosure.c:490
#15 0x0000003306a19d9d in signal_emit_unlocked_R (node=0x7e97e0, detail=0,
instance=0x87d000, emission_return=0x0,
    instance_and_params=0x7fffffa2d800) at gsignal.c:2379
#16 0x0000003306a1b3d5 in IA__g_signal_emit_valist (instance=0x87d000,
signal_id=Variable "signal_id" is not available.
) at gsignal.c:2208
#17 0x0000003306a1b68d in IA__g_signal_emit (instance=Variable "instance" is not
available.
) at gsignal.c:2252
#18 0x0000003891b67298 in ?? ()
#19 0x00007fffffa2ddf0 in ?? ()
#20 0x0000003891c0f6f0 in ?? ()
#21 0x0000003304e07fd0 in ?? () at pthread_mutex_unlock.c:68 from
/lib64/libpthread.so.0
#22 0x00000000006d4240 in ?? ()
#23 0x0000000000000001 in ?? ()
#24 0x0000000000000004 in ?? ()
#25 0x0000000000000160 in ?? ()
#26 0x0000003306a0ace8 in IA__g_closure_invoke (closure=0x6d4240,
return_value=0x7fffffa2dce0, n_param_values=2,
    param_values=0x7fffffa2ddf0, invocation_hint=0x7fffffa2dca0) at gclosure.c:490
#27 0x0000003306a1a5cb in signal_emit_unlocked_R (node=0x6d42b0, detail=0,
instance=0x87d000,
    emission_return=0x7fffffa2dfd0, instance_and_params=0x7fffffa2ddf0) at
gsignal.c:2487
#28 0x0000003306a1b264 in IA__g_signal_emit_valist (instance=0x87d000,
signal_id=Variable "signal_id" is not available.
) at gsignal.c:2218
#29 0x0000003306a1b68d in IA__g_signal_emit (instance=Variable "instance" is not
available.
) at gsignal.c:2252
#30 0x0000003891cd6dc7 in ?? ()
#31 0x0000000000924460 in ?? ()
#32 0x0000000091cda293 in ?? ()
#33 0x0000000000866420 in ?? ()
#34 0x0000000000924460 in ?? ()
#35 0x000000000087d000 in ?? ()
#36 0x0000003891c0aaf5 in ?? ()
#37 0x0000000000000000 in ?? ()
Comment 2 Ian Burrell 2006-01-15 16:56:54 EST
I think this was fixed in rhythmbox CVS.

http://cvs.gnome.org/viewcvs/rhythmbox/player/rb-player-gst.c?r1=1.51&r2=1.52
Comment 3 Ian Burrell 2006-01-29 18:01:26 EST
This bug hasn't been a problem since rhythmbox-0.9.2.cvs20060123-1.x86_64 was
installed.
Comment 4 Matthias Clasen 2006-02-15 16:21:23 EST
Lets assume its fixed, then.

Note You need to log in before you can comment on or make changes to this bug.