Bug 176085 - nfvs4 server cannot authenticate a client against windows kdc kerberos server
nfvs4 server cannot authenticate a client against windows kdc kerberos server
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 03:15 EST by Cristiano Cumer
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0316
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 19:11:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cristiano Cumer 2005-12-19 03:15:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/416.12 (KHTML, like Gecko) Safari/416.13

Description of problem:
When using RHEL4 as nfsv4 server I cannot authehnicate a linux client using a windows KDC
The problem is already resolved by the CITI developer see:
http://linux-nfs.org/pipermail/nfsv4/2005-September/002557.html

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-65.EL4

How reproducible:
Always

Steps to Reproduce:
1) setup a rhel4 nfv4 server
2) setup a linux nfsv4 client
3) setup a windows domain
4) use the windows domain KDC for both the server and the client
5) connect from client to the server
6) try to get a list of files for a user in the domain

Actual Results:  when i try to access an exported filesystem where I have the rights to reaed I get an "permission denied" 
error





Expected Results:  I should be able to access the files

Additional info:
Comment 3 Steve Dickson 2006-08-16 09:12:57 EDT
If possible, could you please test the rpms in
http://people.redhat.com/steved/bz176085/ to see
they fix the problem... tia...
Comment 4 RHEL Product and Program Management 2006-08-18 12:50:49 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Steve Dickson 2006-09-07 03:25:58 EDT
Upstream patch was added to nfs-utils-1.0.6-71.EL4
Comment 8 Red Hat Bugzilla 2007-05-01 19:11:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0316.html

Note You need to log in before you can comment on or make changes to this bug.