Bug 17609 - kickstart won't mount non-linux nfs server exports
Summary: kickstart won't mount non-linux nfs server exports
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkbootdisk   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
: 17240 (view as bug list)
Depends On:
Blocks: 18977
TreeView+ depends on / blocked
 
Reported: 2000-09-18 16:57 UTC by mkd
Modified: 2008-05-01 15:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-28 20:26:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mkd 2000-09-18 16:57:08 UTC
I'm trying to mount an nfs share from a Sun during the %post section of a
kickstart.  When I try to mount the share, it returns "mount failed:
Invalid argument".  I am able to mount share's from a linux NFS server
although.  Upon reboot the machine is able to mount shares exported from
the Sun NFS server without difficulty.  I have also tried mounting shares
from an IRIX machine.  Am I missing something?

Thanks,

Mark

Comment 1 mkd 2000-09-18 20:04:10 UTC
I've spent some more time working on this and realized that I was confusing
chroot and non-chroot situations.  While I have discovered what I was doing
wrong, the initial problem still remains.  In a non-chroot account, I can only
mount nfs directories from a linux server.  I tried referencing the server by
name and by IP with the same results.  In a chroot account, I can mount both
linux and non-linux based NFS servers, by IP only though.

Mark

Comment 2 tek 2000-10-02 21:59:56 UTC
Yep, you are absolutely correct.  Found that out as well.

The problem is it tries to mount with NFS version 3.  The MNT (3) occurs, then 
the GETPORT (2) occurs (both succeed) and then the install dies.  Unless Red 
Hat can guarantee the NFS 3 code works well with all (especially well-
established ver 3 servers like IRIX, Solaris, NetApp), it should have the 
install use ver 2.

My fix was to recompile the anaconda install code, removing the '-DHAVE_NFSV3' 
define in anaconda/isys/Makefile.  I then installed the resulting RPM's, 
rebuilt the install image with the buildinstall command, used the new 
bootnet.img file and voila it mounts my Sun servers just fine.

-Thom

Comment 3 tek 2000-10-02 22:04:05 UTC
I should also add that this is with 7.0 final.  Also, my original problem had 
to do with mounting the NFS install image.  That's the part that failed for me, 
I actually had no difficulties mounting the Sun server during %post.

-Thom

Comment 4 David Ross 2000-10-03 16:44:46 UTC
Yup, same with me - bug #15190.  Don't suppose you could make available your new
bootnet.img?? (Is that all that's required??)

Comment 5 tek 2000-10-03 17:25:08 UTC
Sure, I've put the updated images/ and RedHat/base/ directories <A HREF="http://www.cs.princeton.edu/redhat7-fix/">here</A>.

I think you'll be okay just replacing those two directories in your NFS install image.  You might need to update the instimage directory however, if that's 
the case I've included my updated anaconda RPMS at that URL as well.  Just install those RPM's, then run the 'buildinstall' command in 
/usr/lib/anaconda-runtime giving your install image as an argument.  It appears that for the buildinstall command to work all you need is the 
RedHat/RPMS/ directory to exist with all the RPMS in it, <b>including</b> the <b>updated</b> replacement anaconda RPMS.

-Thom

Comment 6 panu.matilainen 2000-10-10 07:05:58 UTC
Million thanks, your images fixed the problem for me!

Comment 7 Michael Fulbright 2000-10-24 16:40:11 UTC
*** Bug 17240 has been marked as a duplicate of this bug. ***

Comment 8 Need Real Name 2000-12-11 15:44:00 UTC
Good to see that this problem is fixed.

However has the unofficial fix been incorporated to the the official redhat 7
distribution?

If this has not then I am very disappointed with redhat as this problem is quite
a fundamental to the heart of kickstart. I would urge to do this asap if not
done already.



Comment 9 Michael Fulbright 2000-12-18 19:50:56 UTC
I've made a fix available at

ftp://people.redhat.com/msf/bootnet-nfsv2.img



Comment 10 Jeremy Katz 2001-06-28 20:26:19 UTC
*** Bug 46069 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.