Bug 176097 - Untranslated license agreement dialogue
Untranslated license agreement dialogue
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firstboot (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 08:05 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 11:21:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2005-12-19 08:05:44 EST
firstboot-1.3.39-4

firstboot uses eula_strings.py as the source of strings for the translations (as
can be seen in po/firstboot.pot).
However, the strings in eula_strings.py aren't synced with eula.py which
actually uses the translations.

firstboot should use eula.py directly, rather than a useless eula_strings.py

1. Launch firstboot in japanese:
LC_ALL=ja_JP LANG=ja_JP sudo firstboot
2. Decline the license on the second screen
3. Check the dialogue, it says:
Do you want to reread or reconsider the Licence Agreement?                     
                   If not, please shut down the computer and remove this product
from your system.
where the translations (in the .pot, the .po, and the eula_strings.py) say:
Do you want to reread or reconsider the License Agreement?
Comment 1 Bastien Nocera 2005-12-20 04:32:47 EST
Also, it should be "License" in those messages, not "License" (licence is a
verb, not a noun).
Comment 2 Chris Lumens 2005-12-20 10:00:02 EST
For this to happen, redhat-release will need to start shipping translation files
of its own and use its own domain for translation.  We're only using
eula_strings.py right now because nobody else is providing those strings.
Comment 3 Bastien Nocera 2005-12-20 10:01:47 EST
Yeah, the eula.py module is part of redhat-release, and should really contain
its own translations, rather than relying on firstboot to be kept in sync.
Comment 4 Dennis Gregorovic 2006-01-12 11:59:57 EST
Taking ownership of the ticket.  Chris, I'll ping you soon to find out what
needs to be done.
Comment 5 Chris Lumens 2006-02-09 14:20:00 EST
Dennis - any info you need from me on this?
Comment 8 David Lawrence 2006-04-18 16:30:14 EDT
NEEDINFO_ENG has been deprecated in favor of NEEDINFO or ASSIGNED. Changing
status to ASSIGNED for ENG review.
Comment 12 RHEL Product and Program Management 2006-08-18 12:50:09 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 23 RHEL Product and Program Management 2007-04-17 17:23:37 EDT
Although this bugzilla was approved for RHEL 4.5, we were unable
to resolve it in time to be included in the release.  Therefore
it is now proposed for RHEL 4.6.
Comment 25 Chris Lumens 2007-07-10 11:07:06 EDT
We don't have the resources for fixing this in 4.6, so I'm NAKing.
Comment 26 RHEL Product and Program Management 2007-07-10 11:21:40 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.