Bug 176100 - Please do not introduce perl dependency
Please do not introduce perl dependency
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 08:45 EST by Enrico Scholz
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 09:05:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rewrite of namedGetForwarders in shell scripting (4.98 KB, application/x-shellscript)
2007-01-03 10:17 EST, Baris Cicek
no flags Details

  None (edit)
Description Enrico Scholz 2005-12-19 08:45:24 EST
Description of problem:

Please do not introduce a perl dependency by shipping the
/usr/sbin/namedGetForwards in the main package. perl is not required for many
things and I would like to avoid this huge package on my servers.

The dbus stuff is needed for small amount of installations (laptops) only, so I
would recommend to add the related bits into a separate -dbus subpackage (which
is required in turn by things requiring the named dbus functionality).

The 'perl' dep did not exist in previous versions of 'named' and it would be bad
when FC5 would introduce it.


Version-Release number of selected component (if applicable):

bind-9.3.2rc1-1.1
Comment 1 Jason Vas Dias 2005-12-19 11:45:47 EST
OK, I'll remove the perl dependency - namedGetForwarders is an optional extra
"icing on the cake" - but would be quite useful to those using the dbus features.
I don't think we should re-engineer the named dbus support to be in an 
optional sub-package - support for dbus UNIX sockets is in bind-libs, and
so cannot be fully separated from the standard bind package.


Comment 2 Jason Vas Dias 2005-12-20 17:43:52 EST
This is now fixed with bind-9.3.2rc1-2 : bind no longer Requires: perl .
Comment 3 Enrico Scholz 2006-12-20 17:31:42 EST
is back again in FC-6:

| $ rpm -qp i386/bind-9.3.3-0.1.rc3.fc6.i386.rpm  --filerequire | grep perl
| /usr/sbin/namedGetForwarders    /usr/bin/perl perl(Getopt::Std) 
Comment 4 Martin Stransky 2006-12-21 09:05:12 EST
right, because this fix breaks a file coloring.
btw. perl is in the base so it's installed anyway...
Comment 5 Baris Cicek 2007-01-03 10:17:07 EST
Created attachment 144713 [details]
Rewrite of namedGetForwarders in shell scripting

Here's rewrite of namedGetForwarders application rewritten using bash
scripting. Perl might be installed any ways, but at least bind should not be
dependent to perl for just unique application. 

Attached script works completely same way as perl coded one does.
Comment 6 Martin Stransky 2007-01-04 09:41:19 EST
(In reply to comment #5)
> Created an attachment (id=144713) [edit]
> Rewrite of namedGetForwarders in shell scripting

Added to CVS, thanks!

Note You need to log in before you can comment on or make changes to this bug.