Bug 176126 - k3b crashes after kde 3.5 upgrade with
k3b crashes after kde 3.5 upgrade with
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 12:20 EST by Emmanuel Druon
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-04 12:01:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Druon 2005-12-19 12:20:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
After upgrading my kde version last night (from 3.4.2.0 to 3.5.0), k3b crashes when launched. 
Here is the backtrace produced when the application crashes :
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1209132192 (LWP 3336)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#4  0x00530483 in __gnu_cxx::__pool<true>::_M_reclaim_block ()
   from /usr/lib/libstdc++.so.6
#5  0x06993c65 in Arts::readTypeSeq<Arts::InterfaceDef> ()
   from /usr/lib/libmcop.so.1
#6  0x06988c28 in Arts::ModuleDef::readType () from /usr/lib/libmcop.so.1
#7  0x069890aa in Arts::ModuleDef::ModuleDef () from /usr/lib/libmcop.so.1
#8  0x069b436f in Arts::IDLFileReg::startup () from /usr/lib/libmcop.so.1
#9  0x069bc5f2 in Arts::StartupManager::startup () from /usr/lib/libmcop.so.1
#10 0x0699d1d5 in Arts::Dispatcher::Dispatcher () from /usr/lib/libmcop.so.1
#11 0x06e96209 in KArtsDispatcher::KArtsDispatcher ()
   from /usr/lib/libartskde.so.1
#12 0x0808a5c0 in KFileTreeView::slotSetNextUrlToSelect ()
#13 0x0809b86e in QValueList<int>::detachInternal ()
#14 0x0809f228 in QValueList<int>::detachInternal ()
#15 0x0808194b in QValueListPrivate<QString>::QValueListPrivate ()
#16 0x080a003f in QPtrList<K3bPluginFactory>::~QPtrList ()
#17 0x00180d5f in __libc_start_main () from /lib/libc.so.6
#18 0x0807e0f1 in ?? ()

I tried with and without the sound system on but it didn't change anything.


Version-Release number of selected component (if applicable):
k3b-0.11.23-3

How reproducible:
Always

Steps to Reproduce:
1. update to kde 3.5
2. launch k3b
3. observe the crash...
  

Actual Results:  application crashes

Expected Results:  Before kde upgrade, k3b was working fine

Additional info:
Comment 1 Need Real Name 2005-12-19 16:35:47 EST
This is a definite bug:
(note: I have never upgraded my system any other way than 'yum upgrade' - so I
have a standard version of core 4 with standard upgrades)

I am fileing this on behalf of fedoraforum....

k3b won't load after the kde 3.5 upgrade this week....
there are some people that believe that the 'arts' upgrade the same day is what
actually broke it?

To fix it people did this:
(1)'yum install taglib'
(2)download the k3b 12.4a files from http://rpms.xcyb.org/fedora/4/stable/RPMS/
(3)did a 'rpm -Uvh k3b*'

here is the problem:
http://www.fedoraforum.org/forum/showthread.php?t=88851&highlight=gman1
and here is how some people fixed it:
http://forums.fedoraforum.org/showthread.php?t=88784
Comment 2 Eric Tanguy 2005-12-21 06:08:20 EST
I have just gnome installed and kdelibs-3.5.0-0.1.fc4 with arts-1.5.0-0.1.fc4
and k3b-0.11.23-3.
When i launch k3b from command line i obtain : 
$ k3b
kbuildsycoca running...
find: /dev/VolGroup00: Permission non accordée
KCrash: Application 'k3b' crashing...
Unable to start Dr. Konqi
Comment 3 Andreas Bierfert 2005-12-21 07:21:59 EST
Same here since 3.5 upgrade (or maybe arts as I would suspect reading the error
output)...
Comment 4 Bruno Wolff III 2005-12-21 13:28:58 EST
I recently starting seeing crashes after rpm upgrades (including kde 3.5 and
arts 1.5).
Comment 5 Kevin Kofler 2005-12-21 13:29:41 EST
Same here, I guess k3b 0.11.23 is just not compatible with KDE 3.5, so a k3b 
upgrade needs to be pushed. 
Comment 6 Kevin Kofler 2005-12-21 13:50:34 EST
By the way, this mess could probably have been avoided if the KDE 3.5 update  
had been pushed to updates-testing and not directly from Rawhide to FC4.  
Rawhide testing by definition can't uncover version conflicts like that. 
Comment 7 Gian Paolo Mureddu 2005-12-21 15:07:52 EST
I can confirm this. FC4 x86_64 GNOME desktop with KDE libs installed for K3B and
Amarok.

Amarok after an update from Extras was refusing to start, which was solved with
the update of KDElibs 3.5, however K3B which was working just fine, stopped
working as of the update (I actually updated KDElibs before aRTs and the problem
showed with KDElibs). On my system the backtrace is as follows:

(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 46912507923392 (LWP 31983)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#3  0x00000037a8551efe in __gnu_cxx::__pool<true>::_M_reclaim_block ()
   from /usr/lib64/libstdc++.so.6
#4  0x00002aaaab4672be in Arts::readTypeSeq<Arts::InterfaceDef> ()
   from /usr/lib64/libmcop.so.1
#5  0x00002aaaab45c7b5 in Arts::ModuleDef::readType ()
   from /usr/lib64/libmcop.so.1
#6  0x00002aaaab485e40 in Arts::IDLFileReg::startup ()
   from /usr/lib64/libmcop.so.1
#7  0x00002aaaab48d4ee in Arts::StartupManager::startup ()
   from /usr/lib64/libmcop.so.1
#8  0x00002aaaab470601 in Arts::Dispatcher::Dispatcher ()
   from /usr/lib64/libmcop.so.1
#9  0x000000329ff5856e in KArtsDispatcher::KArtsDispatcher ()
   from /usr/lib64/libartskde.so.1
#10 0x000000000045021b in KFileTreeView::slotSetNextUrlToSelect ()
#11 0x000000000045f5d0 in QValueList<int>::detachInternal ()
#12 0x0000000000462c80 in QValueList<int>::detachInternal ()
#13 0x0000000000448752 in QValueListPrivate<QString>::QValueListPrivate ()
#14 0x000000000046388e in QPtrList<K3bPluginFactory>::~QPtrList ()
#15 0x000000310691c3cf in __libc_start_main () from /lib64/libc.so.6
#16 0x0000000000445389 in ?? ()
#17 0x00007fffff8bd718 in ?? ()
#18 0x0000000000000000 in ?? ()

I don't want to resort at installing 3rd party packages so yum won't mess up
when updating.
Comment 8 Harald Hoyer 2005-12-21 16:32:26 EST
there are new k3b packages in the FC4-updates-testing channel. please test, if
these are resolving your issues.
Comment 9 Kevin Kofler 2005-12-21 16:49:13 EST
This fixes it for me. 
Comment 10 Andreas Bierfert 2005-12-21 19:26:34 EST
Fixed here as well  (and layout looks much better now ;))
Comment 11 Need Real Name 2005-12-21 20:33:44 EST
NOT ME....

I installed k3b 0-12.2-1 from http://rpms.xcyb.org/fedora/4/stable/RPMS/ the
other day so to get the new k3b packages(0.11.23-3) I did this:
(1)yum remove k3b*(to get rid of xcyb packages)
(2)yum update(to get k3b 0.11.23-3 and new arts)

here is my output:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1209141568 (LWP 3212)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#4  0x00fe3483 in __gnu_cxx::__pool<true>::_M_reclaim_block ()
   from /usr/lib/libstdc++.so.6
#5  0x00226265 in Arts::readTypeSeq<Arts::InterfaceDef> ()
   from /usr/lib/libmcop.so.1
#6  0x0021b228 in Arts::ModuleDef::readType () from /usr/lib/libmcop.so.1
#7  0x0021b6aa in Arts::ModuleDef::ModuleDef () from /usr/lib/libmcop.so.1
#8  0x0024696f in Arts::IDLFileReg::startup () from /usr/lib/libmcop.so.1
#9  0x0024ec32 in Arts::StartupManager::startup () from /usr/lib/libmcop.so.1
#10 0x0022f7d5 in Arts::Dispatcher::Dispatcher () from /usr/lib/libmcop.so.1
#11 0x05fe7209 in KArtsDispatcher::KArtsDispatcher ()
   from /usr/lib/libartskde.so.1
#12 0x0808a5c0 in KFileTreeView::slotSetNextUrlToSelect ()
#13 0x0809b86e in QValueList<int>::detachInternal ()
#14 0x0809f228 in QValueList<int>::detachInternal ()
#15 0x0808194b in QValueListPrivate<QString>::QValueListPrivate ()
#16 0x080a003f in QPtrList<K3bPluginFactory>::~QPtrList ()
#17 0x067cdd5f in __libc_start_main () from /lib/libc.so.6
#18 0x0807e0f1 in ?? ()
Comment 12 Kevin Kofler 2005-12-21 20:36:05 EST
0.11.23-3 is the old released package, the same one the bug was reported 
against. The one in updates-testing is 0.12.10-0.fc4.1. 
Comment 13 Need Real Name 2005-12-21 21:47:35 EST
OK, sorry....

I have k3b 12.10 installed from testing now....  It loads fine....
-----
I had to remove k3b-mp3 11.24 though to do it....  And can't install it again
because of this yum error:
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package k3b-mp3.i386 0:0.11.24-0.lvn.2.4 set to be updated
--> Running transaction check
--> Processing Dependency: libk3bcore.so.2 for package: k3b-mp3
--> Processing Dependency: libk3bplugin.so.2 for package: k3b-mp3
--> Finished Dependency Resolution
Error: Missing Dependency: libk3bcore.so.2 is needed by package k3b-mp3
Error: Missing Dependency: libk3bplugin.so.2 is needed by package k3b-mp3

that k3b-mp3 plugin probably isn't compatible anyway....  I guess that is a
livna issue....
Comment 14 Kevin Kofler 2005-12-21 21:51:12 EST
Yes, Livna will have to rebuild k3b-mp3 once the upgrade is out officially. 
(The best strategy is probably to just rebuild the k3b-extras they did for the 
development tree, which has support for even more formats. But that's up to 
them, if you want to discuss it, go to bugzilla.livna.org.) 
Comment 15 Kevin Kofler 2005-12-22 19:08:45 EST
k3b-0.12.10-0.fc4.1 is now in the official updates, see: 
https://www.redhat.com/archives/fedora-announce-list/2005-December/msg00087.html 
Just to make sure, I reinstalled it from there, and it still works. I'd say 
this bug can be closed. 

Note You need to log in before you can comment on or make changes to this bug.