Bug 176133 - Please enable Serbian translation to comps
Please enable Serbian translation to comps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 13:00 EST by Igor Miletic
Modified: 2013-01-09 20:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-08 17:31:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Miletic 2005-12-19 13:00:32 EST
Description of problem:
Please enable Serbian translation to comps.

The locale(s) for Serbian are

sr_CS.UTF-8 (default, cyrillic script, available in CVS)
sr_CS.UTF-8@Latn (po files not yet available in CVS, still awaiting to be added
to ACL)

More info on these locales can be found here if needed:
http://srpski.org/locale/

The keyboard for sr_CS is "srp" in XKB. The latin locale sr_CS@Latn uses
"srp(latin)".

The timezone for Serbia and Montenegro is GMT+0100.
Comment 1 Jesse Keating 2006-01-24 19:06:59 EST
I'll touch on this next time I bump comps.
Comment 2 Jesse Keating 2006-01-25 17:47:24 EST
Er, comps already has support for Serbian.  There is a kde-i18n package for it,
and fonts setup for it.  I'm not sure what else we need in comps for this.
Comment 3 Igor Miletic 2006-01-25 22:50:28 EST
There aren't any strings for Serbian in comps.xml. There is translation for both
sr and sr@Latn in CVS (comps-po.po file). 
Comment 4 Jesse Keating 2006-01-26 14:25:19 EST
The following lines are in comps-fc5.in:

  <group>
    <id>serbian-support</id>
    <_name>Serbian Support</_name>
    <_description>Support for Serbian language.</_description>
    <default>false</default>
    <uservisible>false</uservisible>
    <langonly>sr</langonly>
    <packagelist>
      <packagereq type="optional" requires="kdelibs">kde-i18n-Serbian</packagereq>
      <packagereq type="mandatory">fonts-ISO8859-2</packagereq>
      <packagereq type="optional"
requires="xorg-x11">fonts-ISO8859-2-100dpi</packagereq>
      <packagereq type="optional"
requires="xorg-x11">fonts-ISO8859-2-75dpi</packagereq>
    </packagelist>
  </group>

Comment 5 Igor Miletic 2006-01-27 10:53:58 EST
Ok.
But translated strings are not incuded in the package. 

For example:
<name xml:lang="pt">Núcleo</name>
<name xml:lang="pt_BR">Núcleo</name>
<name xml:lang="ru">Основа</name>
<name xml:lang="sk">Jadro</name>
<name xml:lang="sl">Jedro</name>
<name xml:lang="sv">Grund</name>
<name xml:lang="ta">மூலம்</name>
<name xml:lang="th">แกน</name>
<name xml:lang="tr">Çekirdek</name>
<name xml:lang="uk">Основа</name>

As you can see, there aren't any strings for "sr".
Comment 6 Igor Miletic 2006-01-27 10:54:26 EST
Just to add, above is from comps.xml
Comment 7 Miloš Komarčević 2006-01-29 05:19:05 EST
Apart from the missing translated strings, can you also add some new packages
for Serbian support: aspell-sr and openoffice.org-langpack-sr_CS. I guess we
might also need xorg-x11-fonts-cyrillic (if already not installed by default).
Comment 8 Miloš Komarčević 2006-02-06 08:24:31 EST
The translations appeared in comps.xml in the past couple of days, thanks. Now
only missing aspell-sr and openoffice.org-langpack-sr_CS in the "Serbian
Support" group.

Btw, I've noticed the .po files were updated on Feb 3rd, but the
comps-po/comps.pot file wasn't since 2005-04-30?
Comment 9 Bill Nottingham 2006-02-08 17:31:07 EST
Should be fixed.

Note You need to log in before you can comment on or make changes to this bug.