Bug 176167 - gdesklets does not start on x86_64
gdesklets does not start on x86_64
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdesklets (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Luya Tshimbalanga
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 14:43 EST by drago01
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-23 04:27:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file (1.11 KB, text/plain)
2005-12-23 01:56 EST, drago01
no flags Details

  None (edit)
Description drago01 2005-12-19 14:43:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de-DE; rv:1.8) Gecko/20051202 Fedora/1.5-1 Firefox/1.5

Description of problem:
it does not  start on fc4 x86_64 it says "connection to daemon" bu it never finish.
here are the strace output:
socket(PF_FILE, SOCK_STREAM, 0)         = 3
connect(3, {sa_family=AF_FILE, path="/home/dragoran/.gdesklets/sockets/:0.0"},
40) = -1 ENOENT (No such file or directory)
close(4)                                = 0
select(0, NULL, NULL, NULL, {0, 100000}) = 0 (Timeout)
Verbinden mit Daemon [ ###         ]) = 37 "..., 37
socket(PF_FILE, SOCK_STREAM, 0)         = 4
connect(4, {sa_family=AF_FILE, path="/home/dragoran/.gdesklets/sockets/:0.0"},
40) = -1 ENOENT (No such file or directory)
close(3)                                = 0
select(0, NULL, NULL, NULL, {0, 100000}) = 0 (Timeout)
Verbinden mit Daemon [###          ]) = 37 "..., 37
socket(PF_FILE, SOCK_STREAM, 0)         = 3
connect(3, {sa_family=AF_FILE, path="/home/dragoran/.gdesklets/sockets/:0.0"},
40) = -1 ENOENT (No such file or directory)
close(4)                                = 0
select(0, NULL, NULL, NULL, {0, 100000}) = 0 (Timeout)
Verbinden mit Daemon [ ###         ]) = 37 "..., 37
socket(PF_FILE, SOCK_STREAM, 0)         = 4
connect(4, {sa_family=AF_FILE, path="/home/dragoran/.gdesklets/sockets/:0.0"},
40) = -1 ENOENT (No such file or directory)
close(3)                                = 0
select(0, NULL, NULL, NULL, {0, 100000} <unfinished ...>

Version-Release number of selected component (if applicable):
gdesklets-0.35.2-22.fc4

How reproducible:
Always

Steps to Reproduce:
1. try to start it


Actual Results:  it hangs

Expected Results:  it should start

Additional info:
Comment 1 Luya Tshimbalanga 2005-12-20 22:54:04 EST
Did you try the i386 version to see if you have similar problem?
Comment 2 Christian Iseli 2005-12-21 02:25:26 EST
FWIW, it works for me on a pretty Vanilla FC4 x86_64 system...
Seeing you have firefox 1.5 while plain FC4 has 1.0.7, maybe you have
done some incompatible change on your system ?
Comment 3 Luya Tshimbalanga 2005-12-21 04:16:09 EST
(In reply to comment #0)
I noticed you installed rawhide version of Firefox
> User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de-DE; rv:1.8)
Gecko/20051202 Fedora/1.5-1 Firefox/1.5

That might probably explain why gdeskets didn't start due to the conflict with
the browser. Could you provide more details about your system? Like comment #2
pointed out, the problem is mostly related to your system.
Comment 4 drago01 2005-12-21 08:25:04 EST
my system isn't that modifized..
I just recompiled firefox from rawhide without pango and cairo.
all other fedora packages are unmodifized.
why should gdesklets fail to start because of the browser?
it do not even require firefox and the strace shows nothing about it.
Comment 5 Luya Tshimbalanga 2005-12-22 05:04:41 EST
What if you restart some daemons? I consulter other x86_64 users who reported no
issue.
Comment 6 drago01 2005-12-23 01:52:57 EST
I tryed to run it as a different user...
same issue.
what kind of daemons should I restart? which daemons does it use?
Comment 7 drago01 2005-12-23 01:56:06 EST
Created attachment 122554 [details]
log file

here is the log file .. maybe you can find out the problem here
Comment 8 Luya Tshimbalanga 2005-12-23 04:22:41 EST
Looked at the attachment, it appears you have previously installed tarball
version of gdesklets. I strongly suspect that you probably have forgotten to
remove it hence the daemon failed to start.

Taka a look at this line:

in /usr/local/lib/gdesklets/gdesklets-daemon: line 114 ?
in /usr/local/lib/gdesklets/gdesklets-daemon: line 101 _gdesklets_main
in /usr/local/lib/gdesklets/utils/ErrorFormatter.py: line 119 _new_imp
in /usr/local/lib/gdesklets/main/Starter.py: line 1 ?
in /usr/local/lib/gdesklets/utils/ErrorFormatter.py: line 119 _new_imp

The normal path is /usr/lib/gdesklets/

Use that command find /usr -name gdesklets and post it here.
Comment 9 drago01 2005-12-23 04:27:36 EST
ok thx this was it a old tarball install.
(note /usr/lib/ while it should be /usr/lib64)
removed it and now it works.

Note You need to log in before you can comment on or make changes to this bug.