Bug 176194 - unresolvable chain of dependencies for audit-libs/openssh-server
unresolvable chain of dependencies for audit-libs/openssh-server
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: audit (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Grubb
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 17:56 EST by Beth Nackashi
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 13:32:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Beth Nackashi 2005-12-19 17:56:50 EST
Description of problem:
RHEL 4 U1 i386 or RHEL 4 U2 x86_64 machine registered to webqa.  I saw this
problem on two different machines.

Running up2date -uf resulted in the following error:

Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
openssh-server-3.9p1-8.RHEL4.11          requires audit-libs >= 1.0.12

The latest version of audit-libs available on webqa is audit-libs-1.0.3-6.EL4.i386

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1.  Register a RHEL 4 U1 or U2 system to webqa.
2.  Run up2date -uf.
3.
  
Actual results:
[root@test07-64 patches]# rpm -q audit-libs
audit-libs-1.0.3-6.EL4
[root@test07-64 patches]# rpm -qa|grep ssh
openssh-clients-3.9p1-8.RHEL4.9
openssh-3.9p1-8.RHEL4.9
openssh-server-3.9p1-8.RHEL4.9
[root@test07-64 patches]# up2date -uf

Fetching Obsoletes list for channel: rhel-x86_64-as-4...
########################################

Name                                    Version        Rel
----------------------------------------------------------
cups                                    1.1.22         0.rc1.9.9         x86_64
cups-libs                               1.1.22         0.rc1.9.9         x86_64
openssh                                 3.9p1          8.RHEL4.11        x86_64
openssh-clients                         3.9p1          8.RHEL4.11        x86_64
openssh-server                          3.9p1          8.RHEL4.11        x86_64
perl                                    5.8.5          24.RHEL4          x86_64
popt                                    1.9.1          13_nonptl         x86_64
rpm                                     4.3.3          13_nonptl         x86_64
rpm-libs                                4.3.3          13_nonptl         x86_64
rpm-python                              4.3.3          13_nonptl         x86_64
udev                                    039            10.10.EL4.3       x86_64


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
openssh-server-3.9p1-8.RHEL4.11          requires audit-libs >= 1.0.12


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------



Expected results:
Successful update of all packages.  Dependency problems resolved.  That sort of
thing.

Additional info:
Comment 1 Tomas Mraz 2005-12-19 18:00:52 EST
> The latest version of audit-libs available on webqa is 
> audit-libs-1.0.3-6.EL4.i386

Well, this is the problem as newer audit library is really required and it was
scheduled for U3 update as well so it shouldn't be a problem?

Note You need to log in before you can comment on or make changes to this bug.