Bug 176223 - OOo segfaulting on document
OOo segfaulting on document
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 06:13 EST by Maxim Britov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 08:12:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OOo segfaults on this file (35.27 KB, application/vnd.oasis.opendocument.text)
2005-12-20 06:15 EST, Maxim Britov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 59587 None None None Never

  None (edit)
Description Maxim Britov 2005-12-20 06:13:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
OOo segfaults on attached document.
Try open and scroll down.
My gdb output:
(gdb) run test.odt
Starting program: /usr/lib/openoffice.org2.0/program/soffice.bin test.odt
Reading symbols from shared object read from target memory...(no debugging symbols found)...done.
Loaded system supplied DSO at 0xffffe000
[Thread debugging using libthread_db enabled]
[New Thread -1208822096 (LWP 11953)]
warning: Lowest section in /usr/lib/libicudata.so.34 is .hash at 479ce0b4
[New Thread -1226441808 (LWP 11956)]
[New Thread -1234969680 (LWP 11957)]
[New Thread -1245783120 (LWP 11958)]
[New Thread -1265955920 (LWP 11959)]
[New Thread -1279784016 (LWP 11960)]
[New Thread -1288397904 (LWP 11961)]
[Thread -1288397904 (LWP 11961) exited]
[Thread -1279784016 (LWP 11960) exited]
[New Thread -1279784016 (LWP 11963)]
[Thread -1279784016 (LWP 11963) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208822096 (LWP 11953)]
0x4a56090e in osl_acquireMutex () from /usr/lib/openoffice.org2.0/program/libuno_sal.so.3

bt is:
#0  0x4a56090e in osl_acquireMutex () from /usr/lib/openoffice.org2.0/program/libuno_sal.so.3
#1  0xb4aabfc3 in non-virtual thunk to OInputCompStream::closeInput() () from /usr/lib/openoffice.org2.0/program/libxstor.so
#2  0xb4aabff1 in non-virtual thunk to OInputCompStream::closeInput() () from /usr/lib/openoffice.org2.0/program/libxstor.so
#3  0xb4abadbc in OStorage_Impl::ReadContents () from /usr/lib/openoffice.org2.0/program/libxstor.so
#4  0xb4abbb92 in OStorage_Impl::FindElement () from /usr/lib/openoffice.org2.0/program/libxstor.so
#5  0xb4abbee6 in OStorage::hasByName () from /usr/lib/openoffice.org2.0/program/libxstor.so
#6  0x4cb4ca4a in SwMirrorGrf::QueryValue () from /usr/lib/openoffice.org2.0/program/libsw680li.so
#7  0x4cb4da8f in SwMirrorGrf::QueryValue () from /usr/lib/openoffice.org2.0/program/libsw680li.so
#8  0x4cb4db66 in SwMirrorGrf::QueryValue () from /usr/lib/openoffice.org2.0/program/libsw680li.so
#9  0x4b8c633a in GraphicObject::StartAnimation () from /usr/lib/openoffice.org2.0/program/libgo680li.so
#10 0x4b8c3222 in GraphicObject::GetSwapStream () from /usr/lib/openoffice.org2.0/program/libgo680li.so
#11 0x4b8c3e3c in GraphicObject::ImplAutoSwapIn () from /usr/lib/openoffice.org2.0/program/libgo680li.so
#12 0x4b8c465b in GraphicObject::FireSwapInRequest () from /usr/lib/openoffice.org2.0/program/libgo680li.so
#13 0x4b8cd006 in GraphicCacheEntry::TryToSwapIn () from /usr/lib/openoffice.org2.0/program/libgo680li.so
#14 0x4b8cd048 in GraphicCache::GetUniqueID () from /usr/lib/openoffice.org2.0/program/libgo680li.so
#15 0x4b8c6752 in GraphicManager::ImplGetUniqueID () from /usr/lib/openoffice.org2.0/program/libgo680li.so
#16 0x4b8c37f5 in GraphicObject::GetUniqueID () from /usr/lib/openoffice.org2.0/program/libgo680li.so
#17 0x4cb4cae7 in SwMirrorGrf::QueryValue () from /usr/lib/openoffice.org2.0/program/libsw680li.so
#18 0x4cb4da8f in SwMirrorGrf::QueryValue () from /usr/lib/openoffice.org2.0/program/libsw680li.so
#19 0x4cb4db66 in SwMirrorGrf::QueryValue () from /usr/lib/openoffice.org2.0/program/libsw680li.so
#20 0x4b8c633a in GraphicObject::StartAnimation () from /usr/lib/openoffice.org2.0/program/libgo680li.so
#21 0x4b8c3222 in GraphicObject::GetSwapStream () from /usr/lib/openoffice.org2.0/program/libgo680li.so
.......



Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.1-145.3.2

How reproducible:
Always

Steps to Reproduce:
1.open test.odt
2.scroll down
3.gets segf
  

Actual Results:  segfault

Expected Results:  should work without segf :)

Additional info:

http://qa.openoffice.org/issues/show_bug.cgi?id=59587
Comment 1 Maxim Britov 2005-12-20 06:15:27 EST
Created attachment 122442 [details]
OOo segfaults on this file

OOo segfaults on this file
Comment 2 Caolan McNamara 2005-12-20 06:25:59 EST
looks very like a generic oOo issue
Comment 3 Caolan McNamara 2005-12-20 08:12:00 EST
confirmed upstream

Note You need to log in before you can comment on or make changes to this bug.