Bug 176249 - yum update does not notice free disk space
yum update does not notice free disk space
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 11:31 EST by Vadim Ryzhkov
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version: fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:30:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Ryzhkov 2005-12-20 11:31:53 EST
Description of problem:

On the final stage of the "yum update" (no arguments) operation, i.e. after it 
has downloaded all the needed packages (612 packages to be updated of size 1.7 
Gb), run and finished the transaction test, and begun to run the transaction 
itself, it complains that it cannot install some packages like this:

  ('installing package ruby-devel-1.8.3-2.fc4 needs 7MB on the / filesystem', 
(9, '/', 6553600L))

All in all there are 58 similar lines for different packages.

However, there is plenty of free disk space on the / partition:

[root@dhcp0-215 ~]# df
Filesystem 1K-blocks    Used Available Use% Mounted on
/dev/sda1   11173216 7182228 3414260    68% /
...

Moreover, when I restart yum update, it again says that 612 packages need to 
be updated, i.e. it does not update a single package.

Version-Release number of selected component (if applicable):

yum-2.3.2-7

How reproducible:

Every time

Steps to Reproduce:

1. Install the Fedora Core 4 distribution (Everything included on the Packages 
Selection screen)
2. Run yum update

Actual results:

No packages have been updated due to the alleged shortage of disk space.

Expected results:

612 packages should have been updated because there is a lot of free disk 
space.

Additional info:

Not sure if this is relevant, but still:

1) The machine runs in VMWare Workstation 5.0
2) The first time I ran yum update, not all packages could be downloaded 
because the disk space has really run out. Then I copied the contents 
of /var/cache/yum to another directory on another partition, changed 
correspondingly the yum.conf file, restarted the machine (because I do not 
know how to reload the conf file, sorry), ran yum update again. The remaining 
packages were downloaded to the new cache directory, and only then did this 
mistake occur.
Comment 1 Jeremy Katz 2006-04-19 16:30:40 EDT
The way rpm reports the disk space failure is odd, but this should be handled
somewhat better in FC5

Note You need to log in before you can comment on or make changes to this bug.