Bug 176261 - No network at boot with orinoco_cs, > 2.6.14-1.1756_FC5
No network at boot with orinoco_cs, > 2.6.14-1.1756_FC5
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 12:46 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 16:17:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-12-20 12:46:28 EST
In Rawhide kernels newer than 2.6.14-1.1756_FC5, network fails to start at boot
with a Compaq WL110 PCMCIA wireless lan card, using orinoco_cs.

The orinoco_cs module is loaded ok, but a message saying "orinoco_cs device eth1
not present, delaying initialization" is the result when the network is started
and the card tries to get an ip with dhcp.

After bootup, removing the card and reinserting followed by /etc/init.d/network
restart gets the network working ok.  kernel 2.6.14-1.1756_FC5 was the last one
I've tried where things Just Worked without having to do that.

Note, in case it's related, I have these in my modprobe.conf because I couldn't
get the card working with hostap_cs at all:

    alias eth1 orinoco_cs
    blacklist hostap_cs
Comment 1 John W. Linville 2006-01-04 15:32:51 EST
If you switch to a static IP configuration, does the orinoco_cs device work at 
boot? 
Comment 2 Ville Skyttä 2006-01-04 17:10:04 EST
Nope, static vs dhcp does not make any difference.

The card is (from udevinfo):

  looking at class device '/sys/devices/pci0000:00/0000:00:1e.0/0000:02:00.0/0.0':
    KERNEL=="0.0"
    SUBSYSTEM=="unknown"
    SYSFS{card_id}=="0x0002"
    SYSFS{func_id}=="0x06"
    SYSFS{function}=="0x00"
    SYSFS{manf_id}=="0x0156"
   
SYSFS{modalias}=="pcmcia:m0156c0002f06fn00pfn00pa54F7C49Cpb23C40FEApcD27DEB1Apd00000000"
    SYSFS{prod_id1}=="Compaq"
    SYSFS{prod_id2}=="Compaq WL110 PC Card"
    SYSFS{prod_id3}=="Version 01.01"
Comment 3 John W. Linville 2006-01-06 13:10:53 EST
Very strange...have you tried booting with "acpi=off"?  It could be that some 
acpi-related bug is not getting things inited properly at boot...? 
Comment 5 Ville Skyttä 2006-01-07 18:01:37 EST
acpi=off doesn't seem to help.

But here's a log of things I just did:

- Updated to kernel 2.6.15-1.1826.2.4_FC5, booted -> no network at boot
- Rebooted 2.6.15-1.1826.2.4_FC5 with acpi=off -> no network at boot
- Rebooted 2.6.15-1.1826.2.4_FC5 without any special flags
  -> YAY, got network at boot!
- Rebooted to 2.6.15-1.1819_FC5, no special flags -> no network at boot
- Rebooted to 2.6.15-1.1826.2.4_FC5, no special flags -> no network at boot :(

So, I managed to get network properly started *once* at boot with
2.6.15-1.1826.2.4_FC5 without using any special flags.  This is the first time
that has happened since 2.6.14-1.1756_FC5 (up to which network always started ok
at boot and otherwise).
Comment 6 John W. Linville 2006-01-09 12:27:35 EST
FWIW, the orinoco_cs.c source is identical between 2.6.14-1.1756_FC5 and 
2.6.15-1.1826.2.4_FC5. 
 
Have you tried removing the "blacklist hostap_cs" from modprobe.conf since you 
starting having this problem?  Just a shot in the dark... 
Comment 7 Ville Skyttä 2006-01-09 13:08:15 EST
Without "blacklist hostap_cs", I have never got any networking at all with this
card.  Not tested very recently though, but IIRC I tried that when the problems
started.

Googling for "wl110 hostap_cs" (without the quotes) is a good starting point; it
appears that this card is a Lucent one and not a Prism2 one and thus not
supported by hostap_cs.  Nevertheless the Rawhide kernels try to load hostap_cs
for it :(  I wonder if that could be avoided somehow?

Do you know if 2.6.14-1.1756_FC5 (i686, UP) is still available for download
somewhere so I could verify if it would still work ok...?
Comment 8 John W. Linville 2006-01-09 14:21:05 EST
No, I'm don't think the rawhide stuff gets archived like the actual releases 
do... 
Comment 9 John W. Linville 2006-02-07 14:48:38 EST
A month later...is this still a problem? 
Comment 10 Ville Skyttä 2006-02-07 16:13:59 EST
I haven't been using the laptop with which I had these problems in a little
while, but IIRC things seemed to get somewhat better with newer Rawhide updates.
 I did not get networking on every boot, but sometimes anyway.

The laptop is now basically dead and I won't have it next week any more (dead or
alive) anyway, and I doubt I'll even try to resurrect it.  I don't have any
other hardware to test this card with either, so as far as I'm concerned, this
bug can be closed.
Comment 11 Ville Skyttä 2006-02-07 16:16:02 EST
Oh, one more thing: one thing certainly changed with later Rawhide updates: I
did not have to do /etc/init.d/network restart any more, simply
unplugging/plugging the card always brought up the network.
Comment 12 John W. Linville 2006-02-07 16:17:11 EST
Well, it sounds like things were at least getting better...please reopen if 
you do hold-on to the laptop and continue to see the problem...thanks! 

Note You need to log in before you can comment on or make changes to this bug.