Bug 176341 - EDS Crashes when trying to view calendars
EDS Crashes when trying to view calendars
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 11:13 EST by Ryan Skadberg
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 23:37:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace and Output during crash (26.97 KB, text/plain)
2005-12-21 11:13 EST, Ryan Skadberg
no flags Details
More Backtrace, after removing weather calendar (35.69 KB, text/plain)
2005-12-21 11:26 EST, Ryan Skadberg
no flags Details
Last One, another crash with just one webcal (13.94 KB, text/plain)
2005-12-21 11:41 EST, Ryan Skadberg
no flags Details

  None (edit)
Description Ryan Skadberg 2005-12-21 11:13:12 EST
I'll start with this here.

Consitent crash when I switch to the calendar component in Evolution.  EDS
crashes completely.  Backtrace and output from EDS attached.  I tried removing
my weather calendar after seeing this crash and still got the same thing, so it
seems to be something else.

Let me know if you want me to push this upstream.
Comment 1 Ryan Skadberg 2005-12-21 11:13:12 EST
Created attachment 122494 [details]
Backtrace and Output during crash
Comment 2 Ryan Skadberg 2005-12-21 11:13:44 EST
Oh yeah, FYI, saw this is 2.5.2 and now seeing it in 2.5.3.
Comment 3 Ryan Skadberg 2005-12-21 11:26:56 EST
Created attachment 122495 [details]
More Backtrace, after removing weather calendar

Looks like this one was a little better.  Seems like maybe it has something to
do with remote calendars.
Comment 4 Ryan Skadberg 2005-12-21 11:41:41 EST
Created attachment 122497 [details]
Last One, another crash with just one webcal

I removed all my remote calendars (webcal/weather cal) and all worked fine. 
Couled NOT add a weather calendar or remote calendar through evolution.  Went
to the web and let evolution-webcal add a remote webcal and then restarted and
got this crash immediately.  Something seems to be broken with webcals.  Not
sure if its the Red Hat compile or if its Evolution in general.  I un-checked
and checked the plugins and that didn't seem to help.  Is Fedora up to the
correct libsoup version?  Maybe that's the problem??
Comment 5 Dave Malcolm 2005-12-21 16:20:10 EST
Thanks for this bug report, and the great debug information.

Looks like a g_free of a bogus pointer inside e_cal_backend_http_get_object (
possibly the comp string?)

I'm seeing a similar problem in bug 176370, though that's with a free of a comp
string in a different place (weather backend)
Comment 6 Christopher Aillon 2007-04-17 15:16:58 EDT
We probably should push this upstream...
Comment 7 Milan Crha 2007-05-28 05:02:08 EDT
I did try reproduce this on latest evolution 2.11.2 and evolution-data-server
1.11.2 and could not reproduce with one public webcal
webcal://www.azwater.gov/calendar/iCal/resource_type_id/2.ics

I also saw couple of bugs upstream about crash in webcal, (search term "webcal
crash"), unfortunately many of them were closed because could not been reproduced. 

Ryan, could you try to reproduce this bug on latest version of evolution,
please? And if it will be still there and your webcal is not private, could you
send here a link on it so we could try to fix it? Thanks.
Comment 8 Ryan Skadberg 2007-06-14 14:54:46 EDT
As this is from about 3 versions of evolution ago, I woudl just close this :)
Comment 9 Matthew Barnes 2007-06-19 23:37:50 EDT
Closing per reporter's recommendation and inability to reproduce the problem
with the latest releases.

Note You need to log in before you can comment on or make changes to this bug.