Bug 176346 - include paths not added to CFLAGS
include paths not added to CFLAGS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 11:59 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-22 05:53:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2005-12-21 11:59:50 EST
Description of problem:
Compilation against vte is causing problems due to the include paths not being
added to CFLAGS for pkgconfig. In particular, glib, pango and gtk are omitted

Version-Release number of selected component (if applicable):
0.11.16-1.fc5.1

How reproducible:
Alway

Steps to Reproduce:
1. Try to compile anything that requires both glib/pango/gtk with vte

Actual results:
(produced while compiling vte-sharp, part of gtk-sharp for use with mono)

In file included from generated.c:4:
/usr/include/vte/vte.h:28:18: error: glib.h: No such file or directory
/usr/include/vte/vte.h:29:25: error: pango/pango.h: No such file or directory
/usr/include/vte/vte.h:30:21: error: gtk/gtk.h: No such file or directory
In file included from generated.c:4:
/usr/include/vte/vte.h:35: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'typedef'
/usr/include/vte/vte.h:43: error: expected specifier-qualifier-list before
'GtkWidget'
/usr/include/vte/vte.h:64: error: expected specifier-qualifier-list before
'GtkWidgetClass'
/usr/include/vte/vte.h:167: error: expected specifier-qualifier-list before
'GdkColor'
/usr/include/vte/vte.h:175: error: expected specifier-qualifier-list before
'GdkColor'
/usr/include/vte/vte.h:180: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_type'
/usr/include/vte/vte.h:181: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_erase_binding_get_type'
/usr/include/vte/vte.h:182: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_anti_alias_get_type'
/usr/include/vte/vte.h:205: error: expected '=', ',', ';', 'asm' or
'__attribute__' before '*' token
/usr/include/vte/vte.h:209: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:210: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:211: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:216: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:217: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:218: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:222: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:224: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:235: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:235: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:238: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:239: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_audible_bell'
/usr/include/vte/vte.h:240: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:241: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_visible_bell'
/usr/include/vte/vte.h:242: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:243: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:245: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:249: error: expected ';', ',' or ')' before '*' token
/usr/include/vte/vte.h:251: error: expected ';', ',' or ')' before '*' token
/usr/include/vte/vte.h:253: error: expected ';', ',' or ')' before '*' token
/usr/include/vte/vte.h:255: error: expected ';', ',' or ')' before '*' token
/usr/include/vte/vte.h:257: error: expected ';', ',' or ')' before '*' token
/usr/include/vte/vte.h:259: error: expected ';', ',' or ')' before '*' token
/usr/include/vte/vte.h:261: error: expected ';', ',' or ')' before '*' token
/usr/include/vte/vte.h:268: error: expected declaration specifiers or '...'
before 'GdkPixbuf'
/usr/include/vte/vte.h:272: error: expected ';', ',' or ')' before '*' token
/usr/include/vte/vte.h:276: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:279: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:282: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:286: error: expected declaration specifiers or '...'
before 'GtkMenuShell'
/usr/include/vte/vte.h:290: error: expected ';', ',' or ')' before '*' token
/usr/include/vte/vte.h:292: error: expected ';', ',' or ')' before '*' token
/usr/include/vte/vte.h:298: error: expected '=', ',', ';', 'asm' or
'__attribute__' before '*' token
/usr/include/vte/vte.h:299: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_using_xft'
/usr/include/vte/vte.h:300: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:301: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_allow_bold'
/usr/include/vte/vte.h:304: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_has_selection'
/usr/include/vte/vte.h:310: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_is_word_char'
/usr/include/vte/vte.h:319: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:320: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_mouse_autohide'
/usr/include/vte/vte.h:323: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:324: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:333: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:337: error: expected declaration specifiers or '...'
before 'gpointer'
/usr/include/vte/vte.h:338: error: expected declaration specifiers or '...'
before 'GArray'
/usr/include/vte/vte.h:340: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:344: error: expected declaration specifiers or '...'
before 'gpointer'
/usr/include/vte/vte.h:345: error: expected declaration specifiers or '...'
before 'GArray'
/usr/include/vte/vte.h:347: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:347: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:348: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:348: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:349: error: expected declaration specifiers or '...'
before 'gboolean'
/usr/include/vte/vte.h:353: error: expected declaration specifiers or '...'
before 'gpointer'
/usr/include/vte/vte.h:354: error: expected declaration specifiers or '...'
before 'GArray'
/usr/include/vte/vte.h:356: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:356: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:366: error: expected declaration specifiers or '...'
before 'GdkCursor'
/usr/include/vte/vte.h:368: error: expected declaration specifiers or '...'
before 'GdkCursorType'
/usr/include/vte/vte.h:376: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:376: error: expected declaration specifiers or '...'
before 'glong'
/usr/include/vte/vte.h:395: error: expected '=', ',', ';', 'asm' or
'__attribute__' before '*' token
/usr/include/vte/vte.h:396: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_char_width'
/usr/include/vte/vte.h:397: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_char_height'
/usr/include/vte/vte.h:398: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_char_descent'
/usr/include/vte/vte.h:399: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_char_ascent'
/usr/include/vte/vte.h:400: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_row_count'
/usr/include/vte/vte.h:401: error: expected '=', ',', ';', 'asm' or
'__attribute__' before 'vte_terminal_get_column_count'
generated.c:6: error: expected '=', ',', ';', 'asm' or '__attribute__' before
'gboolean'
generated.c:7: error: expected declaration specifiers or '...' before 'gboolean'
generated.c:10: error: expected '=', ',', ';', 'asm' or '__attribute__' before
'vtesharp_vte_charattributes_get_underline'
generated.c:16: error: expected declaration specifiers or '...' before 'gboolean'
generated.c: In function 'vtesharp_vte_charattributes_set_underline':
generated.c:18: error: 'VteCharAttributes' has no member named 'underline'
generated.c:18: error: 'gboolean' undeclared (first use in this function)
generated.c:18: error: (Each undeclared identifier is reported only once
generated.c:18: error: for each function it appears in.)
generated.c:18: error: expected ';' before 'value'
generated.c: At top level:
generated.c:21: error: expected '=', ',', ';', 'asm' or '__attribute__' before
'vtesharp_vte_charattributes_get_strikethrough'
generated.c:22: error: expected declaration specifiers or '...' before 'gboolean'
generated.c:25: error: expected '=', ',', ';', 'asm' or '__attribute__' before
'vtesharp_vte_charattributes_get_strikethrough'
generated.c:31: error: expected declaration specifiers or '...' before 'gboolean'
generated.c: In function 'vtesharp_vte_charattributes_set_strikethrough':
generated.c:33: error: 'VteCharAttributes' has no member named 'strikethrough'
generated.c:33: error: 'gboolean' undeclared (first use in this function)
generated.c:33: error: expected ';' before 'value'
make[3]: *** [generated.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Expected results:
Code should compile without a hitch

Additional info:
Comment 1 Warren Togami 2005-12-25 00:40:09 EST
For this particular bug, as nothing in Core or Extras is affected you should
file upstream at bugzilla.gnome.org.
Comment 2 Paul F. Johnson 2006-01-09 04:08:04 EST
http://bugzilla.gnome.org/show_bug.cgi?id=325030
Comment 3 Paul F. Johnson 2006-01-12 07:16:44 EST
Unfortunately, vte-0.11.16-2 does not fix this problem
Comment 4 Paul F. Johnson 2006-01-12 12:26:59 EST
Rebuilding from source doesn't fix the problem either :-(
Comment 5 Michael J Knox 2006-01-21 16:20:28 EST
This was fixed in gtk-sharp2-2.4.0-2 by Alexander Larsson on Jan 9th. 

Attached Alexander's path to the gnome bug report. 
Comment 6 Kjartan Maraas 2006-01-22 06:40:41 EST
Can we close this and the upstream report then?
Comment 7 Paul F. Johnson 2006-01-22 07:36:23 EST
Probably, however there still seems to be a partial breakage which I'll need to
report.

See #178602 for details
Comment 8 Michael J Knox 2006-01-22 12:47:23 EST
The issue is with gtk-sharp. 

Its obviously not fixed in CVS head, so pulling a CVS version is going to
continue to break. 

You could probably manully patch it yourself untill its fixed: 
http://cvs.fedora.redhat.com/viewcvs/devel/gtk-sharp2/gtk-sharp2-vtelibs.patch?view=markup

The bug and patch have been reported back to the gtk-sharp guys:
http://bugzilla.ximian.com/show_bug.cgi?id=77323

The gnome vte bug report was wrong as its not vte that has the problem. 

Note You need to log in before you can comment on or make changes to this bug.