Bug 176370 - e-d-s crash with a weather calendar
e-d-s crash with a weather calendar
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 16:07 EST by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 15:04:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2005-12-21 16:07:43 EST
Description of problem:
e-d-s bombs out during a free...

#0  0x00c20402 in ?? ()
#1  0x00e9601c in raise () from /lib/libc.so.6
#2  0x00e97483 in abort () from /lib/libc.so.6
#3  0x00eca4cb in __libc_message () from /lib/libc.so.6
#4  0x00ed4e9f in free () from /lib/libc.so.6
#5  0x00485222 in IA__g_free (mem=0x8bde090) at gmem.c:172
#6  0x00b26999 in e_cal_backend_weather_get_object (backend=0x8963780,
cal=0x8969c48, uid=0x8dbab89 "20051221T205549Z-29445-500-1-5@brick",
rid=0x8ac0b49 "", 
    object=0xb68b40fc) at e-cal-backend-weather.c:513
#7  0x001461c7 in e_cal_backend_sync_get_object (backend=0x8963780,
cal=0x8969c48, uid=0x8dbab89 "20051221T205549Z-29445-500-1-5@brick",
rid=0x8ac0b49 "", object=0xb68b40fc)
    at e-cal-backend-sync.c:420
#8  0x001462b2 in _e_cal_backend_get_object (backend=0x8963780, cal=0x8969c48,
uid=0x8dbab89 "20051221T205549Z-29445-500-1-5@brick", rid=0x8ac0b49 "")
    at e-cal-backend-sync.c:798
#9  0x00140979 in e_cal_backend_get_object (backend=0x8963780, cal=0x8969c48,
uid=0x8dbab89 "20051221T205549Z-29445-500-1-5@brick", rid=0x8ac0b49 "") at
e-cal-backend.c:769
#10 0x00149f0c in impl_Cal_getObject (servant=0x8969c5c, uid=0x8dbab89
"20051221T205549Z-29445-500-1-5@brick", rid=0x8ac0b49 "", ev=0xb68b4388) at
e-data-cal.c:208
#11 0x0013b4cb in _ORBIT_skel_small_GNOME_Evolution_Calendar_Cal_getObject
(_o_servant=0x8969c5c, _o_retval=0x0, _o_args=0xb68b4240, _o_ctx=0xb68b42b8,
_o_ev=0xb68b4388, 
    _impl_getObject=0x149ec4 <impl_Cal_getObject>) at
Evolution-DataServer-Calendar-common.c:80
#12 0x002e79bb in IOP_start_profiles () from /usr/lib/libORBit-2.so.0
#13 0x002ed56b in ORBit_OAObject_invoke () from /usr/lib/libORBit-2.so.0
#14 0x002db98b in ORBit_small_invoke_adaptor () from /usr/lib/libORBit-2.so.0
#15 0x002eb389 in ORBit_recv_buffer_return_sys_exception () from
/usr/lib/libORBit-2.so.0
#16 0x002eb9f0 in ORBit_recv_buffer_return_sys_exception () from
/usr/lib/libORBit-2.so.0
#17 0x002d4c9b in giop_thread_queue_process () from /usr/lib/libORBit-2.so.0
#18 0x002d55a3 in giop_init () from /usr/lib/libORBit-2.so.0
#19 0x0049c108 in g_thread_pool_thread_proxy (data=0x8946e08) at gthreadpool.c:114
#20 0x0049a5f5 in g_thread_create_proxy (data=0x8e7e760) at gthread.c:582
#21 0x00c47202 in start_thread () from /lib/libpthread.so.0
#22 0x00f3549e in clone () from /lib/libc.so.6

This is in the g_free in e_cal_backend_weather_get_object
	*object = e_cal_component_get_as_string (comp);
	g_free (comp);


Version-Release number of selected component (if applicable):
evolution-2.5.3-1
evolution-data-server-1.5.3-2


How reproducible:
Not sure yet
Comment 1 Christopher Aillon 2007-04-17 15:17:24 EDT
Has anyone seen this since the original report?  Is this still an issue?
Comment 2 Matthew Barnes 2007-10-02 15:04:12 EDT
Closing as CANTFIX.  Feel free to reopen this if you encounter the problem again
in Fedora 8 Test 2 or later.

Note You need to log in before you can comment on or make changes to this bug.