Bug 176377 - vultureseye and vulturesclaw crash at startup
vultureseye and vulturesclaw crash at startup
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nethack-vultures (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Karen Pease
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 17:59 EST by jlbartos
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-28 11:25:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jlbartos 2005-12-21 17:59:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Galeon/2.0.0

Description of problem:
Both vulturesclaw and vultureseye crash on startup. The previous versions 1.10 didn't have the same problem.

Version-Release number of selected component (if applicable):
nethack-vultures-1.11.0-8.fc4

How reproducible:
Always

Steps to Reproduce:
1.Type vultureseye or vulturesclaw in terminal window.
2.
3.
  

Actual Results:  vultureseye crashes with "Segmentation fault".
vultureclaw crashes with "ALSA lib pcm_dmix.c:832:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:832:(snd_pcm_dmix_open) unable to open slave
ERROR: could not open log file jtp_log.txt for appending: Permission denied
[vultures_sdl.c: 509] ERROR: Could not initialize SDL audio device
: No available audio device"

Expected Results:  Program should have started.

Additional info:

I have all the latest updates.
Comment 1 Karen Pease 2005-12-21 19:59:52 EST
I'm on it.  :) 
Comment 2 Karen Pease 2005-12-21 20:11:40 EST
Actually, would you mind waiting a couple days?  There's a new release that's 
current propagating its way through the works that should show up soon, which 
has some significant bugfixes.  Lets see if you still get the problems with 
that version.  I can link to you a prerelease if you would like. 
 
 
Comment 3 jlbartos 2005-12-22 05:08:41 EST
(In reply to comment #2)
> Actually, would you mind waiting a couple days?  There's a new release that's 
> current propagating its way through the works that should show up soon, which 
> has some significant bugfixes.  Lets see if you still get the problems with 
> that version.  I can link to you a prerelease if you would like. 
>  
>  

I don't mind waiting. I just posted the bug, because nobody else has.

If you have a link to a prerelease I wouldn't mind giving it a try.
Comment 4 Karen Pease 2005-12-22 11:01:27 EST
Ok, I put them up on my site.  You can get either the binary or source RPM at: 
 
http://www.daughtersoftiresias.org/progs/nethack/ 
 
Let me know if that fixes your problem.  If not, I'm going to have to dig, 
because I just checked that RPM and it works on my system. 
 
Comment 5 jlbartos 2005-12-23 05:31:38 EST
I have nethack-vultures-1.11.1-2.fc4 and vultureseye is now working.

Vulturesclaw is still crashing with error:

ERROR: could not open log file jtp_log.txt for appending: Permission denied
[/usr/games/vulturesclaw/vulturesclaw]: Program initialization has failed.
Program initialization has failed.
ERROR: could not open log file jtp_log.txt for appending: Permission denied
[/usr/games/vulturesclaw/vulturesclaw]: Report error to "games".
Report error to "games".
ERROR: could not open log file jtp_log.txt for appending: Permission denied
[/usr/games/vulturesclaw/vulturesclaw]: could not initalize graphic mode
could not initalize graphic mode
Comment 6 Karen Pease 2005-12-23 23:37:08 EST
Bug is reproduced.  I'm on it.   
Comment 7 Karen Pease 2005-12-24 01:33:01 EST
Figured it out.  Working on a patch. 
 
Comment 8 Karen Pease 2005-12-24 01:49:05 EST
Patch is in.   Check out version 1.11.1-3 when it propagates, and let me know 
if you're all set so that I can close this bug.  FYI: I'll be out on Xmas break 
starting tomorrow, so my access may be a touch sporadic. 
  
Summary:  
To save space, the binary was removing the slash'em graphics, doc, and sound  
directories, preferring instead to symlink them to the vultureseye version of  
those directories.  However, the build process was apparently changed on me in  
the most recent tarball, and some graphics files were now only going to one of  
the two directories, thus leaving slash'em shortchanged.  The solution was to  
copy all of the slash'em graphics files over to the nethack graphics dir before  
rm'ing and symlinking.  
 
Comment 9 jlbartos 2005-12-27 16:08:46 EST
nethack-vultures-1.11.1-3.fc4

Works for me.

Thanks.
Comment 10 Karen Pease 2005-12-28 11:25:12 EST
Great!  Closing. 

Note You need to log in before you can comment on or make changes to this bug.