Bug 176390 - dhclient-script has invalid conditional assumption
dhclient-script has invalid conditional assumption
Status: CLOSED DUPLICATE of bug 176270
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 20:27 EST by lannet
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: dhcp-3.0.2-28_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 20:46:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lannet 2005-12-21 20:27:37 EST
Description of problem:
dhclient-stript, at line 279, reads:
if [ -z "$router" ] || [ `IFS=. ip2num $router` -le 0 ] || [[ $router = *255* ]]
|| [[ "${default_routers[@]}" == *"$router"* ]]; then

I believe that the regex "*255*" should read "*255"

I discovered this because my local gateway is 192.168.255.1 and when I ran the
script it did not insert a default gateway.  When I changed the regex to "*255"
the default gateway was inserted.


Version-Release number of selected component (if applicable):
Dec 15 07:22 updates/dhclient-3.0.2-26.FC4.i386.rpm

How reproducible:
Try with a gateway of 192.168.255.xxx set as an option in /etc/dhcpd.conf

Steps to Reproduce:
1.  see above
2.
3.
  
Actual results:
No default gateway inserted 

Expected results:
Default gateway expected

Additional info:
nil
Comment 1 Jason Vas Dias 2005-12-21 20:46:00 EST
This problem was reported earlier in bug 176270, and was fixed with the current
dhcp-3.0.2-28.FC4, now in FC-4 Updates/Testing (and available from the testing
repositories and download.fedora.redhat.com). 
I guess I'll push this to Updates tomorrow.

Very sorry for the problems this bug may have caused .

*** This bug has been marked as a duplicate of 176270 ***

Note You need to log in before you can comment on or make changes to this bug.