Bug 176418 - Cannot remove unneeded driver rpms
Cannot remove unneeded driver rpms
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-22 09:53 EST by Mephisto
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 21:11:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mephisto 2005-12-22 09:53:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
The xorg-x11-drivers package is required by xorg-x11-server-Xorg, which in turn requires *all* drivers to be installed. Isn't the ability to only install needed components one of the main reasons to have things modular? I'd like to be able to remove drivers for devices i won't ever gonna put in my system.

Version-Release number of selected component (if applicable):
xorg-x11-drivers-0.99.2-4

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to modular xorg
2.
3.
  

Actual Results:  I had to install all x.org drivers

Expected Results:  I should be able to pick a few that i need and leave out the rest.

Additional info:
Comment 1 Mike A. Harris 2006-01-31 21:11:04 EST
(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051216
Fedora/1.5-3 Firefox/1.5
> 
> Description of problem:
> The xorg-x11-drivers package is required by xorg-x11-server-Xorg, which in
> turn requires *all* drivers to be installed.

Yes, that is something requested by the installer team, and is intentional.

> Isn't the ability to only install needed components one of the main
> reasons to have things modular?

There are a great many benefits that modularization of X.org sources
intended to provide.  The upstream sources are provided in a highly
granular manner, to allow individual distributions to determine their
own packaging granularity in a manner that best suits their own needs,
as it was determined by X.Org that different distributions may have
different granularity requirements or other preferences.

> I'd like to be able to remove drivers for devices i won't ever gonna put
> in my system.

The entire set of drivers consumes around 5Mb or so, which is negligible
considering the size of the entire OS currently.  Every OS release prior
to this one has required that all drivers be installed also.  That was
just because they were all included in a single tarball however.  There
are other reasons why all drivers are required to be installed at all
times.


> Actual Results:  I had to install all x.org drivers
> 
> Expected Results:  I should be able to pick a few that i need and leave out
the rest.

The complexity involved in resolving all of the problems that arise if random
drivers are uninstalled, in order to make all of the config tools work properly,
and handle situations like a user installing only a single video driver, then
changing cards months later and wondering why the driver for their new card
isn't present, and various other similar problems, is simply not worth the
effort.  It is a total support nightmare, unless enough time is spent
engineering the config tools and rest of the distribution to be able to
handle hardware autodetection cases in which the driver is not presently
installed on the system, and inform the user nicely somehow of this, so
they can install or download the driver.   Without such support, bugzilla
would be rather riddled with bug reports about drivers missing, or not
being installed.

Aside from all of this however, there is currently a development effort
underway to make the X server config file unnecessary.  In the future,
the X server will directly detect the video hardware at runtime, and
automatically load the correct driver.  When that happens, it will only
work if all of the drivers are installed.

The anaconda team (installer team), and various others have told me that
there is no plan on having the tools updated to handle individual driver
installation, due to the fact the effort is not worth it, in particular
since it's only saving a maximum of a couple of megs of space.

So, unless this changes, and the anaconda team, system-config-display
and other config tool developers, Fedora Core technical lead, and numerous
other Fedora Core developers change their mind about allowing individual
driver installation/removal, the X drivers will remain mandatorily installed
in X packaging, currently enforced by the xorg-x11-drivers package.

Individuals who desperately want to save $0.0001 worth of hard disk space
can however customize the xorg-x11-drivers src.rpm if desired to not have
hard dependencies on all drivers, and their custom package once installed,
should allow them to uninstall unwanted drivers.  I'm not sure it is worth
all the time and effort to do that for $0.0001 worth of disk space however,
but that's just my opinion.  ;o)

Closing as "NOTABUG", as this is an intentional packaging feature,
implemented at request of installer team, and aside from that to
preemptively reduce incoming "my driver isn't provided by Fedora"
bug reports from users who have uninstalled (or not installed) all
drivers from happening.


Note You need to log in before you can comment on or make changes to this bug.