Bug 176436 - Anaconda recovery from failure caused by volume group name conflict
Anaconda recovery from failure caused by volume group name conflict
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
ia64 Linux
high Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
: FutureFeature
Depends On:
Blocks: 184165
  Show dependency treegraph
 
Reported: 2005-12-22 15:30 EST by Satoshi OSHIMA
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 19:00:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/anacdump.txt (632.12 KB, text/plain)
2005-12-22 15:33 EST, Satoshi OSHIMA
no flags Details
/tmp/lvmout (2.32 KB, text/plain)
2005-12-22 15:34 EST, Satoshi OSHIMA
no flags Details
information about existing partitions (2.56 KB, text/plain)
2006-01-05 17:14 EST, Satoshi OSHIMA
no flags Details

  None (edit)
Description Satoshi OSHIMA 2005-12-22 15:30:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When attempting to install RHEL4 U3 Beta for ia64 from USB cdrom
on Hitachi Blade Symphoney, the installer failed before 
repartitioning.

Installation fail every time when choosing auto partitioning 
and user select partitioning with disk druid.

HDD of this hardware contains RHEL4U2 and choosing to remove
previously existing partitions.

The error message is below.

---------------------------------------------------------
Red Hat Enterprise Linux AS (C) 2004 Red Hat, Inc.
               +------------+ Exception Occurred +-------------+
               |                                               |
               | An unhandled exception has occurred.        # |
               | This is most likely a bug.  Please copy     # |
               | the full text of this exception and file    # |
               | a detailed bug report against anaconda at   # |
               | http://bugzilla.redhat.com/bugzilla/        # |
               |                                             # |
               | Traceback (most recent call last):          # |
               |   File "/usr/bin/anaconda", line 1173, in   # |
               | ?                                           # |
               |     intf.run(id, dispatch, configFileData)  # |
               |   File                                      # |
               | "/usr/src/build/664004-ia64/install//usr/l  # |
               | ib/anaconda/text.py", line 510, in run      # |
               |     dispatch.gotoNext()                     # |
               |   File                                      # |
               | "/usr/src/build/664004-ia64/install//usr/l  # |
               | ib/anaconda/dispatch.py", line 171, in      # |
               | gotoNext                                    # |
               |     self.moveStep()                         # |
               |   File                                      # |
               | "/usr/src/build/664004-ia64/install//usr/l  # |
               | ib/anaconda/dispatch.py", line 239, in      # |
               | moveStep                                    # |
               |     rc = apply(func, self.bindArgs(args))   # |
               |   File                                      # |
               | "/usr/src/build/664004-ia64/install//usr/l  # |
               | ib/anaconda/packages.py", line 564, in      # |
               | turnOnFilesystems                           # |
               |     partitions.doMetaDeletes(diskset)       # |
               |   File                                      # |
               | "/usr/src/build/664004-ia64/install//usr/l  # |
               | ib/anaconda/partitions.py", line 1205, in   # |
               | doMetaDeletes                               # |
               |     lvm.lvremove(delete.name, delete.vg)    # |
               |   File                                      # |
               | "/usr/src/build/664004-ia64/install//usr/l  # |
               | ib/anaconda/lvm.py", line 143, in lvremove  # |
               |     raise SystemError, "lvremove failed"    # |
               | SystemError: lvremove failed                # |
               |                                               |
               |        +----+               +-------+         |
               |        | OK |               | Debug |         |
               |        +----+               +-------+         |
               |                                               |
               |                                               |
               +-----------------------------------------------+



Version-Release number of selected component (if applicable):
RHEL4U3Beta.ia64(disc1)

How reproducible:
Always

Steps to Reproduce:
1. Install from USB CDROM on Hitachi Blade Symphoney.
2. Choose "Remove all existing Linux Partitions"
3. Start installation.
  

Actual Results:  Installation fails.

Expected Results:  Installation Starts.

Additional info:

I will attach additional information.
Comment 1 Satoshi OSHIMA 2005-12-22 15:33:29 EST
Created attachment 122535 [details]
/tmp/anacdump.txt

/tmp/anacdump.txt
Comment 2 Satoshi OSHIMA 2005-12-22 15:34:39 EST
Created attachment 122536 [details]
/tmp/lvmout

/tmp/lvmout
Comment 3 James Laska 2006-01-05 13:12:49 EST
Can we reproduce this easily?  If so, can you indicate what the partition table
and LVM layout looks like prior to installing?

# for all disks
$ parted /dev/$DISK -s p

# Also grab existing LVM details
$ pvdisplay
$ vgdisplay
$ lvdisplay
Comment 4 Satoshi OSHIMA 2006-01-05 17:14:17 EST
Created attachment 122847 [details]
information about existing partitions

attaching the information about existing partitions.
I pulled up this information using rescue cd.

I can see that Logical Volume is not consistent.

But RHEL4U2 worked fine on this server just before 
installing RHEL4U3Beta.
Comment 5 Peter Jones 2006-01-06 11:32:21 EST
Have you changed the disk configuration at all between installing RHEL4U2 and
U3Beta?  This looks like you've added a disk, or split up a hardware RAID1.
Comment 6 Satoshi OSHIMA 2006-01-06 11:58:24 EST
I need to explain this server hardware.

It has 2 RAID Controlers. Each Controler has 2 Logical Unit.

RAID1-+-LU0(sda)
      |
      +-LU1(sdb)

RAID2-+=LU0(sdc)
      |
      +-LU1(sdd)

And I have never changed this configuration.

But second RAID controller is sometimes removed
from this server and sdc includes another copy of
RHEL4U2 for *another server*.

I have never changed partition setting nor LVM 
configuration neither. So the only chage is RAID 
controller #2 removal and reconnect.

*note that OS that place in sda doesn't mount sdc 
nor sdd.

Comment 8 Peter Jones 2006-01-09 12:00:59 EST
What's happening here is that you're adding a second raid, and the LVM volume
group on it has the same name as that on the first device.  This won't work; you
need to either remove or rename one of the volume groups before putting them
both on the same system.
Comment 12 Larry Troan 2006-03-06 21:34:03 EST
Reopening bug for RHEL5 consideration. Changing summary to more accurately
reflect the request.
Comment 18 Larry Troan 2006-03-21 18:53:08 EST
This looks a lot like another bug to resolve multiple volumes with the same
name. Can't remember the bug number off hand but will try to dig it up.
Comment 20 Larry Troan 2006-07-24 13:45:21 EDT
Per my comment #18, this is the bug from Hitachi (Issue Tracker wording is a
little different which triggered comment #18) -- I can't find any other
bugzillas with similar content.
Comment 21 Issue Tracker 2006-08-15 00:10:29 EDT
Removing BZ176436 from IT85287. This issue are addressed to BZ147361 for
lvm2 and to BZ200252 for anaconda.



This event sent from IssueTracker by kmori 
 issue 85287
Comment 23 RHEL Product and Program Management 2006-09-20 19:00:08 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 24 Larry Troan 2006-10-02 15:58:46 EDT
Per private comment #22 above, Peter Jones couldn't fix this for RHEL4 and
has had the same difficulty in trying to fix it on RHEL5:
> Comment #9 From Peter Jones (pjones@redhat.com)   on 2006-01-09 12:02 EST 
>
> The way the lvm tools address the drives needs to change before we can
> reasonably fix this bug.  Until the underlying tools treat volume groups
> with the same name but different UUIDs as different VGs, there's very
> little we can do.

Therefore Engineering has now declined the request for RHEL5 as well.

Note You need to log in before you can comment on or make changes to this bug.