This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 176441 - col -b truncates data
col -b truncates data
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-22 15:40 EST by Wayne Walker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 12:59:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Walker 2005-12-22 15:40:25 EST
Description of problem:
cat data thru col -b, col -b truncates the stream

Version-Release number of selected component (if applicable):
util-linux-2.12p-9.12


How reproducible:
Very

Steps to Reproduce:
1. cat /usr/share/doc/mutt-1.4.2.1/manual.txt | col -b | wc
  
Actual results:
375


Expected results:
6297

Additional info:
wc -l /usr/share/doc/mutt-1.4.2.1/manual.txt
yields:
6297 /usr/share/doc/mutt-1.4.2.1/manual.txt

Other files yield similar results:

[ (0) wwalker@behemoth:~ ]$ cat mysql/5.0/manual.html | wc
 113827  695996 7764064
[ (0) wwalker@behemoth:~ ]$ cat mysql/5.0/manual.html | col -b | wc
     15     892   15048
Comment 1 Karel Zak 2006-01-02 11:03:13 EST
There is a problem in the files, because wide chars conversion by getwchar()
fails.  Well, the col command should be more talkative about this problem. I'll
change it and for errno==EILSEQ it will returns 1 (as for the others errors).
Comment 2 Karel Zak 2006-01-03 12:59:15 EST
Fixed in FC4 and FC5. Now the col command reports information about failed wide
character conversion:

  $ cat /usr/share/doc/mutt-1.4.2.1/manual.txt | ./col > /dev/null
  col: Invalid or incomplete multibyte or wide character


Note You need to log in before you can comment on or make changes to this bug.