Bug 176448 - rawhide kernel 1777 panics starting udev, kernel 1783 oopses (sysfs?)
rawhide kernel 1777 panics starting udev, kernel 1783 oopses (sysfs?)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-22 17:21 EST by Andy Burns
Modified: 2015-01-04 17:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-05 20:37:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug console output (19.56 KB, text/plain)
2005-12-22 17:31 EST, Andy Burns
no flags Details

  None (edit)
Description Andy Burns 2005-12-22 17:21:19 EST
Description of problem:

Presume this is ok to log as kernel bug rather than udev bug?

Clean install of rawhide 2005-12-22, installation all ok, at first reboot kernel
panic when starting udev, I rebooted with debug instead of quiet to see if it
would repeat, that time it made it as far as firstboot gui then hung, on about
ten subsequent reboots (some with debug, some with quiet) it always panics at
starting udev.

Version-Release number of selected component (if applicable):

2.6.14-1_1777_FC5smp

How reproducible:

Apparently 100% now, I've not cold started machine yet, and not tried to
re-install yet.

Steps to Reproduce:
1. boot newly installed rawhide
  
Actual results:

Starting udev kernel panic not syncing bad locking
Comment 1 Andy Burns 2005-12-22 17:31:44 EST
Created attachment 122542 [details]
debug console output

I've attached a debug console log, nothing jumps out at me, and it has already
reached init before the panic happens ...
Comment 2 Andy Burns 2005-12-22 18:51:35 EST
A cold boot made no difference, wiped and re-installed and get identical
problem, so very reproducible (for me)

I guess the one time it made it as far as firstboot gui ans then hung was a fluke.
Comment 3 Andy Burns 2005-12-23 09:29:35 EST
I noticed that today's (2005-12-23) rawhide got a udev update as well as a new
kernel, so though I'd see if it helped this bug, it still doesn't boot but this
time with a oops instead of a panic

http://adslpipe.co.uk/pxeboot.jpg

I checked afterwards and the same happens with a cd boot as well as the pxe
boot, I did get the text portion of anaconda to start with 
"debug console=ttyS0,115200" on the command line, but anaconda
couldn't see a video card that way, perhaps that's to be expected.

I guess Santa's not bringing me a bootable kernel or installable rawhide this
year ;-) Back for more next week ...

Running anaconda, the Fedora Core system installer - please wait...           
QTraceback (most recent call last):
File "/usr/bin/anaconda", 
  line 1136, in ?instClass.setInstallData(id, intf)
File "/usr/lib/anaconda/kickstart.py", 
  line 730, in setInstallData self.ksparser.readKickstart(self.file)
File "/usr/lib/python2.4/site-packages/pykickstart/parser.py", 
  line 928, in readKickstart self.handleCommand(lineno, args)
File "/usr/lib/anaconda/kickstart.py", 
  line 632, in handleCommand self.handler.handlers[cmd](self.id, cmdArgs)
File "/usr/lib/anaconda/kickstart.py", 
  line 525, in doXConfig dict["startX"])
File "/usr/lib/anaconda/installclass.py", 
  line 416, in configureX self.setVideoCard(id, driver, videoRam)
File "/usr/lib/anaconda/installclass.py", 
  line 397, in setVideoCard import rhpxl.videocard 
  ImportError: No module named rhpxl.videocard
install exited abnormally

Comment 4 Andy Burns 2005-12-23 09:43:26 EST
Just one quick extra ..

I saw others recommending "acpi=off" and "irqpoll" as workarounds for latest
rawhide kermels, tried both, no difference with 1783
Comment 5 Dave Jones 2005-12-23 14:04:00 EST
can you file a seperate anaconda bug for the traceback ? That looks unrelated to
the panic you see.  (Which is a little puzzling, but I'm looking into it)
Comment 6 Andy Burns 2005-12-23 14:38:50 EST
The anaconda traceback never happened with the panic on 1777 kernel, it only
happened with 1783 kernel which usually oopses, even then anaconda only gave the
traceback once when using a serial console, if using vga/tty1 it always oopses
before any sign of the text part of anaconda, even on the serial console usually
the "language selection" menu in anaconda is hung as soon as it is displayed.

Just once anaconda was not hung when I used the PS/2 keyboard rather than the
USB one (strangely this machine usually has both plugged in) but that time
anaconda didn't detect a network card to load stage2 from (despite having just
pxe'ed off it) 

I thought about filing an anaconda issue, but it felt like anaconda was
suffering at the hands of the kernel and/or udev issues, I'll see if I can find
any pattern repoducible enough to report as a "useful" anaconda bug ...

Comment 7 Andy Burns 2005-12-23 15:30:52 EST
Ahh, I just discovered things are not as bad as they seemed, just that I was
using yet another flakey win32 terminal emulator, anaconda runs ok (to a point)
on a serial console, but causes the oops when using vga/tty1.

<off topic>
hyperterm does such a crap job of any emulation it's barely usable,

tera term is old and unmaintained and does wierd things like create 10000xzero
pixel sized windows quite frequently

I though I'd found a good one in tutty (putty with COM: ports added) but
apparently not, it seems to hang up on line drawing characters

I don't think I have a valid licence for any recent version of R4 which used to
be my vt emulator of choice

I might have to rewire the console to another linux box instead and use minicom,
unless anyone has recommendation for good free win32 vt emulator?

</off topic>

Comment 8 Andy Burns 2005-12-30 09:55:19 EST
I've tested rawhide 2005-12-30 using x86_64 instead of i386 and it also oopses
in essentially the same way see http://adslpipe.co.uk/64bitoops.jpg

Comment 9 Andy Burns 2006-01-05 20:37:17 EST
working again with kernels 1805_FC5 or later

Note You need to log in before you can comment on or make changes to this bug.