Bug 176463 - kcalc built with low precision in latest kdeutils update
kcalc built with low precision in latest kdeutils update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-22 22:53 EST by Steven Schwarz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-16 13:55:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Schwarz 2005-12-22 22:53:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
It appears that kcalc was built wrong (with insufficient precision) in the latest update to fedora core 4. The previous version worked fine (kdeutils-3.4.2-0.fc4.1). I checked and there appear not to be any changes to the kcalc sources between these versions, so I conclude the problem is in how kcalc was built this time as opposed to last time.

Version-Release number of selected component (if applicable):
kdeutils-3.5.0-0.1.fc4

How reproducible:
Always

Steps to Reproduce:
To demonstrate the problem, bring up kcalc, ensure that the default precision settings are in the kcalc configuration, and do the following computation:

123456.78 + 123456.78 = ?

Actual Results:  With the latest version you get 246,914.

Expected Results:  With the previous version you get the correct answer, 246913.56.

Additional info:
Comment 1 Ngo Than 2005-12-23 10:52:01 EST
ít's a bug in new version of kcalc.
Comment 2 Ngo Than 2006-01-16 13:55:40 EST
it's now fixed in CVS kde upstream. The fixes is included in rawhide.

Note You need to log in before you can comment on or make changes to this bug.