Bug 176469 - Resolving some site failed in wget
Resolving some site failed in wget
Status: CLOSED DUPLICATE of bug 186592
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-23 01:28 EST by sangu
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 04:52:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace wget http://people.redhat.com/davej/kernels/Fedora/devel/readme.txt (16.05 KB, text/plain)
2005-12-23 01:28 EST, sangu
no flags Details

  None (edit)
Description sangu 2005-12-23 01:28:15 EST
Description of problem:

$wget http://people.redhat.com/davej/kernels/Fedora/devel/readme.txt
--15:27:09--  http://people.redhat.com/davej/kernels/Fedora/devel/readme.txt
           => `readme.txt'
Resolving people.redhat.com... failed: No such file or directory.

but lftp, firefox, epiphany is success.

Version-Release number of selected component (if applicable):
1.10.2-3.1

How reproducible:
always


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 sangu 2005-12-23 03:33:44 EST
$wget --inet4-only http://people.redhat.com/davej/kernels/Fedora/devel/readme.txt
is success.

Using option --inet4-only, this problem is fixed.

Because of bug 174927 , does this problem happen ?

----
glibc-2.3.90-22
Comment 3 Karsten Hopp 2006-01-02 09:51:31 EST
174927 is a different problem. 
You can also try to disable the IPV6 address of your network device if you don't
need IPV6. This would speed up DNS-lookups as a sideaffect.
I'll close this report as there's a workaround and it is unclear if this is a
wget, a network or a server-side problem on people.redhat.com.
Comment 4 sangu 2006-01-02 11:04:46 EST
in /etc/modprobe.conf
[...]
alias net-pf-10 off
alias ipv6 off
[...]
The same problem happens.

$nslookup people.redhat.com
Server:         168.126.63.1
Address:        168.126.63.1#53

Name:   people.redhat.com
Address: 66.187.233.237
wget can't download file in all sites.

And similar problem happens in liferea, yum, bittorrent, xchat.

So adding addresses in/etc/hosts, I have fixed this problem. 

But this problem doesn't happen in the other applications (like epiphany, pan,
evolution, gftp).
Is this dns server problem?

Anyway, thank your comment.
Comment 5 Daniel Malmgren 2006-01-28 07:33:25 EST
This bug really should be reopened and classed as major. I don't know what
causes it, but for me it started yesterday after a major yum update. And I don't
get it just for some addresses, but the affected programs (so far I've seen it
in wget, yum and xchat) doesn't seem to be able to resolve any addresses at all.
I was forced to manually add dozens of addresses in /etc/hosts to get the
programs to work again.
Comment 6 sangu 2006-02-14 22:33:20 EST
Daniel Malmgren : 

--- My situation ---
$ ls -al /etc/nsswitch.conf
-rw-r--r-- 1 root root 1750 Nov 17  2002 /etc/nsswitch.conf

But /etc/nsswitch.conf is in glibc-2.3.90-37
-rw-r--r-- 1 root root 1696 Sep 23  2004 /etc/nsswitch.conf

So copy nsswitch.conf in glibc package.

And this problem doesn't happen.


Comment 7 Daniel Malmgren 2006-02-24 07:14:22 EST
(In reply to comment #6)
> Daniel Malmgren : 
> 
> --- My situation ---
> $ ls -al /etc/nsswitch.conf
> -rw-r--r-- 1 root root 1750 Nov 17  2002 /etc/nsswitch.conf
> 
> But /etc/nsswitch.conf is in glibc-2.3.90-37
> -rw-r--r-- 1 root root 1696 Sep 23  2004 /etc/nsswitch.conf
> 
> So copy nsswitch.conf in glibc package.
> 
> And this problem doesn't happen.

Yep. Exactly the same for me. Thanks a lot!

My nsswitch was dates 2001. The difference between that and the recent glibc one
was that the hosts line in the new one said "files dns", whilst the old one said
"files nisplus dns". I guess something got broken with nisplus. Maybe this bug
should be reopened with component set to glibc?
Comment 8 Aaron Sherman 2006-04-26 14:37:07 EDT
Is this a dup of bug #186592 ?
Comment 9 Jakub Jelinek 2006-05-16 04:52:12 EDT
This looks like a dup of #186592 and #186592 has been fixed even in FC5 recently
https://www.redhat.com/archives/fedora-package-announce/2006-May/msg00065.html


*** This bug has been marked as a duplicate of 186592 ***

Note You need to log in before you can comment on or make changes to this bug.