Bug 176482 - k3b crashes on startup after recent kde update
k3b crashes on startup after recent kde update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: arts (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-23 02:57 EST by john bray
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-23 06:34:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john bray 2005-12-23 02:57:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Since installing the new kde update (20 dec 2005), k3b crashes on startup.  i can see the splash screen.  it's last message is something about creating the gui.

while i can't say for sure that this only started with the new update, i know it has not worked since then.  i believe i used k3b the day before the update and had it work as had been usual.  but, then, i've slept since then.

Version-Release number of selected component (if applicable):
k3b-0.11.23-3   and  arts-1.5.0-0.2.fc4

How reproducible:
Always

Steps to Reproduce:
1.click on k3b in applications| sound & video menu
2.
3.
  

Actual Results:  crashes and puts up crash screen.

Expected Results:  heh.  i'd have prefered that it'd continued it's startup and let me copy a disk.  :-)

Additional info:

crash info provided in k3b crash screen:  

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1209129280 (LWP 2081)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#4  0x00a4a483 in __gnu_cxx::__pool<true>::_M_reclaim_block ()
   from /usr/lib/libstdc++.so.6
#5  0x00460265 in Arts::readTypeSeq<Arts::InterfaceDef> ()
   from /usr/lib/libmcop.so.1
#6  0x00455228 in Arts::ModuleDef::readType () from /usr/lib/libmcop.so.1
#7  0x004556aa in Arts::ModuleDef::ModuleDef () from /usr/lib/libmcop.so.1
#8  0x0048096f in Arts::IDLFileReg::startup () from /usr/lib/libmcop.so.1
#9  0x00488c32 in Arts::StartupManager::startup () from /usr/lib/libmcop.so.1
#10 0x004697d5 in Arts::Dispatcher::Dispatcher () from /usr/lib/libmcop.so.1
#11 0x0014baa9 in KArtsDispatcher::KArtsDispatcher ()
   from /usr/lib/libartskde.so.1
#12 0x0808a5c0 in KFileTreeView::slotSetNextUrlToSelect ()
#13 0x0809b86e in QValueList<int>::detachInternal ()
#14 0x0809f228 in QValueList<int>::detachInternal ()
#15 0x0808194b in QValueListPrivate<QString>::QValueListPrivate ()
#16 0x080a003f in QPtrList<K3bPluginFactory>::~QPtrList ()
#17 0x047d6d5f in __libc_start_main () from /lib/libc.so.6
#18 0x0807e0f1 in ?? ()
Comment 1 Ngo Than 2005-12-23 06:34:49 EST
please update to new k3b-0.12.10-0.fc4.1 from FC4-update, it should fix this
problem. Thanks for your report

Note You need to log in before you can comment on or make changes to this bug.