This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 176490 - segmentation fault line 23:2009
segmentation fault line 23:2009
Status: CLOSED DUPLICATE of bug 176724
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 176491 176495 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-23 10:04 EST by raxet
Modified: 2014-03-16 22:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-01 02:02:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description raxet 2005-12-23 10:04:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Fedora/1.7.12-3

Description of problem:
During boot, "Checking for hardware changes /etc/rc5.d/S05kudzu: line 23:2209 Segmentation fault /sbin/kudzu $KUDZU_ARGS"

Version-Release number of selected component (if applicable):
kudzu-1.2.16-1

How reproducible:
Always

Steps to Reproduce:
1. boot
2. error
3.
  

Actual Results:  Checking for hardware changes /etc/rc5.d/S05kudzu: line 23:2209 Segmentation fault /sbin/kudzu $KUDZU_ARGS

Expected Results:  kudzu loads normally

Additional info:
Comment 1 Bill Nottingham 2005-12-23 22:36:38 EST
*** Bug 176495 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2005-12-23 22:36:46 EST
*** Bug 176491 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2005-12-23 22:41:53 EST
If you run it by hand, does it still segfault?
Comment 4 raxet 2005-12-24 00:22:02 EST
Running in terminal and typing kudzu segfaults.
Comment 5 raxet 2005-12-26 18:08:29 EST
Now it's segfaulting on line 23:2196 after todays update
Comment 6 Bill Nottingham 2005-12-26 23:36:18 EST
It's not segfaulting in a stock config for me. Can you get a gdb backtrace
(preferably with kudzu-debuginfo installed)?
Comment 7 raxet 2005-12-27 19:16:31 EST
When I try a gdb bt on the process I get virtually nothing:
Starting program: /usr/sbin/kudzu
Reading symbols from shared object read from target memory...(no debugging
symbols found)...done.
Loaded system supplied DSO at 0x991000
(no debugging symbols found)
(no debugging symbols found)

Program received signal SIGSEGV, Segmentation fault.
0x00a11466 in free () from /lib/libc.so.6
Comment 8 raxet 2005-12-27 19:29:13 EST
So it's glibc-2.3.90-22 that may be the issue..
Comment 9 Robert Scheck 2005-12-29 09:17:53 EST
Is it possible, that this bug is another duplicate of bug #176573 and #176583?
Comment 10 Gianluca Cecchi 2005-12-29 09:32:13 EST
Analyzing commands in /etc/rc.d/init.d/kudzu, it seems that the offending line 
is:
kudzu -z || kudzu
Tipically I have sometimes the illegal option error, sometimes not, 
and it happens with the second kudzu command in the line
So I tried a two times sequence with: 
[root fedora ~]#  kudzu -z ||gdb  kudzu
GNU gdb Red Hat Linux (6.3.0.0-1.94rh)
Copyright 2004 Free Software Foundation, Inc. 
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db 
library "/lib/libthread_db.so.1".

(gdb) run
Starting program: /sbin/kudzu
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0x3b4000

Program exited normally.
(gdb) quit

[root fedora ~]#  kudzu -z ||gdb  kudzu
GNU gdb Red Hat Linux (6.3.0.0-1.94rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions. 
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db 
library "/lib/libthread_db.so.1". 

(gdb) run
Starting program: /sbin/kudzu
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0x745000

Program received signal SIGILL, Illegal instruction. 
0x0805ee2f in run_vm86 () at lrmi.c:733
733             asm volatile (
(gdb)
(gdb) quit
The program is running.  Exit anyway? (y or n) y


HIH,
Gianluca
Comment 11 Bill Nottingham 2005-12-31 23:45:53 EST
Gianluca  - you've got a different error - that's a LRMI thing. You have
1.2.16-1, correct?
Comment 12 Bill Nottingham 2006-01-01 01:44:42 EST
raxet: Can you attach your lspci (and lspci -n) output?
Comment 13 Bill Nottingham 2006-01-01 02:02:37 EST
Fixed in 1.2.17-1.

*** This bug has been marked as a duplicate of 176724 ***
Comment 14 Gianluca Cecchi 2006-01-02 15:00:48 EST
yes Bill, I have 1.2.16-1.
Do I have to open a different bug number?
Comment 15 Bill Nottingham 2006-01-06 14:22:47 EST
Please do.

Note You need to log in before you can comment on or make changes to this bug.