Bug 176529 - Wrong owner of /var/log/munin
Wrong owner of /var/log/munin
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: munin (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-24 05:05 EST by Dariusz Garbowski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 12:48:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dariusz Garbowski 2005-12-24 05:05:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051204 SeaMonkey/1.5a

Description of problem:
/var/log/munin is owned by root, while /etc/cron.d/munin runs cron jobs as user munin. This causes logger to fail with:

Warning: Could not open log file "/var/log/munin/munin-update.log" for writing: Permission deniedDec 24 01:10:04 - Starting munin-update
...
...

Making /var/log/munin owned by munin:munin makes the issue go away.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:
Comment 1 Kevin Fenzi 2005-12-24 11:18:42 EST
This was an issue with the 'munin-node' subpackage. It had /var/log/munin as
root:root (since it runs as root and can write it's logs fine). The main munin
package had it's /var/log/munin setup as 'munin:munin', but if you installed
node after the main package, it changed the ownership of that directory. 

It should be fixed in the next release that I have just pushed out for build...
1.2.4-5. 

If you could retest after updating to that version, and confirm that it fixes
the bug that would be great. 
Comment 2 Dariusz Garbowski 2006-01-09 06:01:12 EST
Installed it the same way I did the first time and it looks ok now (note: I
don't have Extras enabled on my box so it's a "manual" install):

[root@cpc2-oxfd8-4-0-cust64 20060109]# rpm -Uvh
/mnt/1/downloads/fedora3/munin-*1.2.4-5.fc3.noarch.rpm
Preparing...                ########################################### [100%]
   1:munin-node             ########################################### [ 50%]
   2:munin                  ########################################### [100%]
[root@cpc2-oxfd8-4-0-cust64 20060109]# ll -d /var/log/munin
drwxr-xr-x  2 munin munin 4096 Dec 24 16:20 /var/log/munin

Thanks!
Comment 3 Dariusz Garbowski 2006-01-09 06:06:07 EST
Additional note: I have actually removed previous munin packages (rpm -e munin
munin-node) and moved /var/log/munin out of the way so that it had to be created
again by rpm and *not* just "upgraded" (as the -U option for rpm would suggest).
Comment 4 Kevin Fenzi 2006-01-09 12:48:54 EST
Excellent. Thanks for bug report and feedback. 
If you spot any further issues, just file a new bug. 

Note You need to log in before you can comment on or make changes to this bug.