Bug 176543 - /usr/lib/rpm/rpmv: free(): invalid pointer
Summary: /usr/lib/rpm/rpmv: free(): invalid pointer
Status: CLOSED DUPLICATE of bug 162037
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
(Show other bugs)
Version: 4
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-25 11:43 UTC by Roman E. Kuskov
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 22:09:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output error log (11.57 KB, text/plain)
2005-12-25 11:47 UTC, Roman E. Kuskov
no flags Details

Description Roman E. Kuskov 2005-12-25 11:43:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i586; U;) Gecko/20021203

Description of problem:
After installing FC4 x86_64 and updating the kernel from 2.6.11-1.1369 to 2.6.14-1.1653 I've got an error while running rpm -Va command:

*** glibc detected *** /usr/lib/rpm/rpmv: free(): invalid pointer: 0x0000000000b0e84f ***

rpm -Va with old kernel (2.6.11-1.1369) works fine.
Update of rpm package to 4.4.1-22 didn't solve the problem.

Version-Release number of selected component (if applicable):
rpm-4.4.1-22

How reproducible:
Always

Steps to Reproduce:
1. Install FC4 x86_64. rpm -Va works fine.
2. Install new kernel packages kernel-2.6.14-1.1653_FC4, kernel-devel-2.6.14-1.1653_FC4 and reboot with new kernel.
3. Run rpm -Va.
  

Actual Results:  crash

Expected Results:  no crash

Additional info:

Complete output log will be attached.

Comment 1 Roman E. Kuskov 2005-12-25 11:47:13 UTC
Created attachment 122575 [details]
output error log

Output error log.

Comment 2 Roman E. Kuskov 2005-12-25 12:01:51 UTC
The problem has disappeared after building and installing the rpm-4.4.2-7
packages from FC5Test1 SRPMS. Please provide the correct updates for FC4
(because built rpm's from FC5Test1 can't be isntalled directly).


Comment 3 Jeff Johnson 2006-01-07 16:06:22 UTC
NEEDINFO_ENG waiting for FC4 update release.

Comment 4 Paul Nasrat 2006-03-29 22:09:19 UTC

*** This bug has been marked as a duplicate of 162037 ***


Note You need to log in before you can comment on or make changes to this bug.