Bug 176547 - unable to open udev_db '/dev/.udev/db'
unable to open udev_db '/dev/.udev/db'
Status: CLOSED DUPLICATE of bug 176041
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-25 10:13 EST by Kevin Verma
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 05:07:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kevin Verma 2005-12-25 10:13:38 EST
Description of problem:

After applying the udev update version 078-2, I noticed the following error in
/var/log/messages

Dec 25 11:48:35 server1 udevinfo[1874]: udev_db_get_all_entries: unable to open
udev_db '/dev/.udev/db': No such file or dir
ectory

This restricted to have most of the dynamically created devices in the /dev
directory.

I had to investigate this problem when I could not log into this system running
FC5 test1 via ssh, after applying the udev & kernel update. The error mesages I
could locate then upon ssh login failure under /var/log/secure were as below:

sshd (pid): Accepted public key for root from 192.168.0.3
sshd (pid): pam_unix(sshd:session): session opened for user root by (uid=0)
sshd (pid): error: openpty: no such file or directory
sshd (pid): session_pty_req: session 0 alloc failed

I carefully checked even /dev/pts was mounted and I tried to remount it, but
that did not helped. As discussed on Fedora-devel list, an update to initscripts
was also given a try but that did not helped either, finally a fall back to
udev-75-4 solved the problem and no related log message of udev as subjected
above was seen. 

Seems a new feature of a implimenting a DB file could not locate the expected
file, hence file seems missing for the new version 078-2.
Comment 1 Kevin Verma 2005-12-25 10:18:52 EST
I am a dodo, filled the bug report for release notes instead !

That was my first bug report on bugzilla, I am sorry for being a jerk and will
file it in proper place.

Regrets,
Comment 2 Rahul Sundaram 2005-12-25 10:21:55 EST

Ok. You can afford to be a jerk now and then ;-). 

Reassigned to the right component. Thank you for your bug report. Happy holidays 
Comment 3 Hans de Goede 2006-01-05 05:19:37 EST
I've seen this too, it sames to come and go. I have a felling that it happens
when booting a different kernel then the boot before, but I'm not sure.
Comment 4 Harald Hoyer 2006-01-11 05:07:59 EST

*** This bug has been marked as a duplicate of 176041 ***

Note You need to log in before you can comment on or make changes to this bug.