Bug 176550 - garbage in generated dependecies
garbage in generated dependecies
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnston
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-25 12:03 EST by Dan Horák
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 15:12:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of dependency with garbage (42.95 KB, text/plain)
2005-12-25 12:03 EST, Dan Horák
no flags Details
good dependencies created manually with the Eclipse-generated makefile (8.55 KB, text/plain)
2005-12-25 13:13 EST, Dan Horák
no flags Details

  None (edit)
Description Dan Horák 2005-12-25 12:03:39 EST
Description of problem:
The files with Eclipse generated source file dependencies contains some garbage
characters. I am compiling an example application for Ogre 3D framework
(http://www.ogre3d.org).


Version-Release number of selected component (if applicable):
eclipse-cdt-3.0.0_fc-1.FC4
eclipse-platform-3.1.1-1jpp_1fc.FC4.4


How reproducible:


Steps to Reproduce:
1. build project
  
Actual results:
Dependency with garbage
  ...
  /home/dan/devel/include/OGRE/OgreCommon.h \
  /home/dan/devel/include/OGRE/OgreResourceGroupManager.h \
  /home/dan/devel/include/OGRE/OgreSingl........................................
eton.h \
  /home/dan/devel/include/OGRE/OgreScriptLoader.h \
  ...

The "." after "OgreSingl" is UTF-8 character #1048064 (as says editor from
Midnight Commander). There are cca 6500 copies of this character. I have
attached the file.



Expected results:
Good dependency


Additional info:
When I run the makefile manually, then the dependencies are OK. I have tested it
also on a second computer with the same versions of Eclipse and FC4 and the
result is the same.
Comment 1 Dan Horák 2005-12-25 12:03:40 EST
Created attachment 122577 [details]
example of dependency with garbage
Comment 2 Dan Horák 2005-12-25 13:13:59 EST
Created attachment 122578 [details]
good dependencies created manually with the Eclipse-generated makefile
Comment 3 Dan Horák 2005-12-25 13:14:42 EST
I have tried now to create a C++ project using wxWidgets. And the dependencies
are wrong again. It looks like that during the build they are created with the
makefile (and they don't have the text "Automatically-generated file - do not
edit" included) and after the build they are processed in Eclipse (the "do not
edit" text is added) and the result is a garbage.
Comment 4 Andrew Overholt 2006-01-07 10:55:59 EST
I'm on it.
Comment 5 Dan Horak 2006-01-10 17:26:39 EST
I have looked into the sources of eclipse-cdt
(org.eclipse.cdt.managedbuilder.core) and from what I can see, the bug must be
in some lower layer (gcj?). CDT uses mostly "append" methods from StringBuffer
to modify or create the generated (make-)files. I do not see any reason for this
garbage-generation behaviour.
Comment 6 Ben Konrath 2006-10-04 15:11:20 EDT
This bug is filed against FC4 which is no longer supported. Please re-test with
FC5 or FC6 and reopen the bug if the problem still exists. Thanks.

Note You need to log in before you can comment on or make changes to this bug.