This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 176555 - digikam cannot load libexif.so.9 which isn't listed as a dependancy in the rpm
digikam cannot load libexif.so.9 which isn't listed as a dependancy in the rpm
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: digikam (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-26 00:23 EST by Aran Cox
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-26 00:31:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aran Cox 2005-12-26 00:23:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
[spin@cain ~]$ digikam
digikam: error while loading shared libraries: libexif.so.9: cannot open shared object file: No such file or directory

[spin@cain ~]$ rpm -q digikam libexif
digikam-0.8.0-1.fc4
libexif-0.6.12-3

spin@cain ~]$ ldd /usr/bin/digikam |grep libexif
        libexif.so.12 => /usr/lib/libexif.so.12 (0x005b6000)
        libexif.so.9 => not found

rpm -qR digikam | grep libexif
libexif.so.12

Basically, I can't get digikam to start because it wants libexif.so.9.  The RPM doesn't list that as a dependancy however and the libexif rpm doesn't provide it either.  However, using ldd shows that digikam is linked against the 9 version of libexif.  Or is it possible that some other library that digikam uses requires it?



Version-Release number of selected component (if applicable):
digikam-0.8.0-1.fc4

How reproducible:
Always

Steps to Reproduce:
1. invoke digikam
2.
3.
  

Actual Results:  [spin@cain ~]$ digikam
digikam: error while loading shared libraries: libexif.so.9: cannot open shared object file: No such file or directory


Expected Results:  The program should have opened.


Additional info:
Comment 1 Aran Cox 2005-12-26 00:31:39 EST
It seems that for whatever reason I had a libkexif from the kde-redhat project
from fc3 installed and it wasn't getting upgraded by yum.  It required
libexif.so.9.  When I removed it and installed libkexif from extras, the problem
was gone.  

Note You need to log in before you can comment on or make changes to this bug.