Bug 176564 - Fedora Wiki invalid HTML
Fedora Wiki invalid HTML
Status: CLOSED UPSTREAM
Product: Fedora Infrastructure
Classification: Retired
Component: website (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Websites Team
Elliot Lee
http://fedoraproject.org/wiki/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-26 09:54 EST by Damian Myerscough
Modified: 2007-04-18 13:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-21 01:17:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Myerscough 2005-12-26 09:54:46 EST
Description of problem:
Fedora Wiki page contains invalid HTML, when checked with the w3c website.


Steps to Reproduce:
1. Click the link "Valid HTML" in the bottom right corner.
2.
3.
  
Actual results:
 Failed validation, 8 errors

Expected results:
 Validation Pass.


Additional info:
Most of the bugs produced can be fixed with styles e.g.

Error  Line 96 column 88: there is no attribute "BORDER".

...png"  alt="Fedoraproject.org" border="1" style="position: absolute; top: 0px;

Change the style to:

...png" alt="Fedoraproject.org" style="position: absolute; top: 0px; border: 1px;"

There are some other pages that do not validate and will require editing.
Comment 1 Rahul Sundaram 2006-01-14 02:28:51 EST

Would you like to contribute and get this fixed?. I can get you wiki access. See
http://fedoraproject.org/wiki/WikiEditing for more information. 
Comment 2 Damian Myerscough 2006-01-14 07:28:57 EST
Hi,

I have wiki editing access, I just can seem to see all the source code
in the wiki editor
Comment 3 Patrick Barnes 2006-01-14 07:48:13 EST
The problems may be part of the MoinMoin code.  I intend to look into this as
soon as I have the time.  In the meantime, you are welcome to download MoinMoin
from http://moinmoin.wikiwikiweb.de/ (we're using version 1.3.4) and set up a
personal installation to see if you can find the problems there.  If you are
able to produce patches, I'd love to see them.
Comment 4 Patrick Barnes 2006-10-21 01:17:37 EDT
Since most of these problems stem from upstream MoinMoin, the fixes need to be 
applied upstream so that the wiki may inherit them with future updates.  We 
won't fork the wiki to make the fixes locally.

I'm closing this bug as UPSTREAM.  Thanks for your attention.

Note You need to log in before you can comment on or make changes to this bug.