Bug 176605 - Udev uses NSS which may require network unavailable during boot
Summary: Udev uses NSS which may require network unavailable during boot
Status: CLOSED DUPLICATE of bug 169725
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-27 12:35 UTC by Pawel Salek
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 09:45:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pawel Salek 2005-12-27 12:35:05 UTC
Description of problem:
Recent changes to udev as distributed in the development version of FC started
to use some NSS calls which in case of networked machines with eg. nss_ldap
enabled will end up making network connections. Network devices are however not
available that early in the booting stage when udev is started which leads to an
apparent hang. nss_ldap times out after two minutes - fortunately! - but I am
not sure all other networked name services do. At best, it's a nuisance that
adds two minutes to the booting process.

Version-Release number of selected component (if applicable):
udev-078-3

How reproducible:
Always

Steps to Reproduce:
1. add ldap keywords to /etc/nsswitch.conf, eg
passwd:     files ldap
2. reboot.
3. watch the computer apparently hang during udev startup.
  
Additional info:

This bug has been introduced in a period between Dec 23 and Dec 27.

Comment 1 Harald Hoyer 2006-01-11 09:45:15 UTC

*** This bug has been marked as a duplicate of 169725 ***


Note You need to log in before you can comment on or make changes to this bug.