Bug 176649 - smbclient fails to login in tar creating mode
smbclient fails to login in tar creating mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
: 189502 191159 (view as bug list)
Depends On:
Blocks: 191159
  Show dependency treegraph
 
Reported: 2005-12-28 11:06 EST by Tomasz Ostrowski
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 12:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 3974 None None None Never

  None (edit)
Description Tomasz Ostrowski 2005-12-28 11:06:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When using smbclient in tar creating mode, like this:
    smbclient //server/share -A server.auth -Tc /tmp/server-share.tar
there is an login failure although a command
    smbclient //server/share -A server.auth
logs in just fine.



Version-Release number of selected component (if applicable):
samba-3.0.20b-2.1

How reproducible:
Always

Steps to Reproduce:
1. smbclient //server/share -A server.auth -Tc /tmp/server-share.tar


Actual Results:  session setup failed: NT_STATUS_LOGON_FAILURE

Expected Results:  Domain=[DOMAIN] OS=[Windows NT 4.0] Server=[NT LAN Manager 4.0]
tar: dumped 5 files and directories
Total bytes written: 22577664


Additional info:

My configuration is an NT domain with Windows NT 4 server with latest service pack.

Smbclient from vanilla version of samba-3.0.20b works just fine (compiled with ./configure --prefix=/tmp/samba-3.0.20b.root && make CFLAGS=-O0 && make install). Smbclient from Fedora Core 4 also works fine but I cannot use it because of bug #167561.
Comment 1 Tomasz Ostrowski 2005-12-28 11:49:18 EST
When I recompiled samba rpm without samba-3.0.15pre2-bug106483.patch it worked.
Comment 2 Tomasz Ostrowski 2006-07-28 09:28:26 EDT
The cause of this is that tar creating option arguments of smbclient are
confused with password provided in command line. This is an upstream bug. I've
filed it in upstream bug tracker and I'm adding a reference to
https://bugzilla.samba.org/show_bug.cgi?id=3974
Comment 3 Les Mikesell 2007-02-16 15:55:43 EST
Are there known workarounds for this?  Backuppc will do full backups using smb
mode but fails authentication on incrementals.
Comment 4 Simo Sorce 2007-02-16 16:00:31 EST
have you tried to use -Uusername%password on the command line?
Comment 5 Les Mikesell 2007-02-16 17:26:55 EST
Backuppc normally sets the PASSWD variable so the password isn't visible to ps,
but the same thing happens if the %password is added to the username.  It works
with a command like:
smbclient \\\\host\\share -U backupuser -E -N -d 1 -c tarmode\ full -Tc -
but fails with 
smbclient \\\\host\\share -U backupuser -E -N -d 1 -c tarmode\ full -TcN
/path/to/timestampfile -
regardless of the way the password is handled. 
If the password is omitted, neither way will prompt for it as documented and
done by earlier versions.
Comment 6 Simo Sorce 2007-03-23 19:05:31 EDT
*** Bug 189502 has been marked as a duplicate of this bug. ***
Comment 7 Simo Sorce 2007-03-23 19:10:29 EDT
*** Bug 191159 has been marked as a duplicate of this bug. ***
Comment 8 Simo Sorce 2007-03-28 12:14:16 EDT
Committing the fix to fc5,fc6 and rawhide.
Thank you very much for the report.

Note You need to log in before you can comment on or make changes to this bug.