From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.2 (like Gecko)
Description of problem:
According to how I read the documentation, chapter 22.1.3. "Dependency tags"
says that RPM supports the following syntax:
Requires: perl(IO-Wrap) == 4.5 or perl(IO-Wrap)-4.5
this does not actually seem to be the case. May I please ask for
clarification: is this a planned feature that didn't get implemented yet, or
is the documentation wrong?
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. Add the above Requires tag to a spec file
2. Build the spec file
3. Observe the resulting requires with ``rpm -qp --requires'' or similar.
Actual Results: The package ends up with three requirements, which obviously makes no sense:
perl(IO-Wrap) == 4.5
Expected Results: An "either A or B" kind of requirement.
rpm does not support aletrnation (i.e. ||) of requires, never has. No current plans (or need) to add the
Either the doco you are reading is incorrect, or you are not reading correctly.
I would ask that you reconsider adding such a feature. Nothing currently
supported allows this functionality, as discussed in the following thread:
Being able to specify a logical-OR would solve numerous common issues such as
capitalization problems (e.g., MySQL-devel vs. mysql-devel), naming convention
discrepencies (gtk+ vs. gtk1 vs. gtk), and so forth.
If I were to open an RFE for such a feature, would it be considered? Or is this
bug considered the RFE? (It seems more like a "documentation error" report to me.)