Bug 176689 - wrong number of buttons detected on mouse
wrong number of buttons detected on mouse
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-29 21:50 EST by Valdis Kletnieks
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 07:09:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2005-12-29 21:50:31 EST
Description of problem:
The current mouse driver misdetects the number of mouse buttons on my Microsoft
Trackball Optical - it has 7, the driver detects 11.

Version-Release number of selected component (if applicable):
xorg-x11-drv-mouse-1.0.3-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

From /var/log/Xorg.0.log -

(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "ExplorerPS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Buttons" "7"
(**) Option "Emulate3Buttons" "on"
(**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "6 7"
(**) Mouse0: ZAxisMapping: buttons 6 and 7
(**) Mouse0: Buttons: 11
Comment 1 Valdis Kletnieks 2005-12-29 22:00:17 EST
Testing with 'xev' shows that what should be buttons 1-7 are in fact seen as 1,
2, 3, 6, 7, 8, 9.  I found the problem when xmodman complained:

xmodmap -e "pointer = 1 7 2 6 3 4 5"
xmodmap:  commandline:1:  bad number of buttons, must have 11 instead of 7
xmodmap:  1 error encountered, aborting.
Comment 2 Valdis Kletnieks 2005-12-29 23:32:51 EST
Wow. It's not a bug, it's a feee-ture.

https://bugs.freedesktop.org/show_bug.cgi?id=4915

What I *used* to have was xmodmap -e "pointer = 1 7 2 6 3 4 5" (which basically
moved mouse buttons 2 and 3 to physical buttons I preferred).

Now I have to use xmodmap -e "pointer = 1 7 2 6 9 4 5 8 3 10 11" (injecting
gratuitous non-existent 8-11 - 8 and 9 as padding are irritating).

I'm not sure *how* to document this user-visible change - in particular, note
that xmodmap is usable by users, who will have to work around any ZAxisMapping
that the sysadmin set up.....
Comment 4 Mike A. Harris 2006-02-02 03:53:13 EST
Please upgrade to xorg-x11-drv-mouse-1.0.3.1-1 and update the report to indicate
if the problem still exists in the current build.  Some bugs were fixed at the
last minute which may resolve this.

TIA
Comment 5 Mike A. Harris 2006-02-09 07:09:07 EST
Assuming this is resolved in the latest packages as there has been no
feedback for over a week.

If the problem still exists in the latest packages, after reconfiguring
the X server from scratch with system-config-display and system-config-mouse,
please reopen with updated details.

Setting status to "RAWHIDE".

Note You need to log in before you can comment on or make changes to this bug.