Bug 17672 - ftp install with password prompts for password twice
Summary: ftp install with password prompts for password twice
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-19 06:42 UTC by Jeremy Katz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-19 06:43:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
take care of asking for double passwords during ftp install of rpms (609 bytes, patch)
2000-09-19 06:43 UTC, Jeremy Katz
no flags Details | Diff

Description Jeremy Katz 2000-09-19 06:42:26 UTC
rpm has been calling getpass() twice to get the password for a
non-anonymous ftp installs since between Red Hat 6.0 and 6.1 (rpm 3.0 and
3.0.3).  This change comes as a direct consequence of changing the way the
password is gotten to using xstrdup, as the expansion of the macro gives
two calls of getpass().  Patch against HEAD to instead just call getpass()
instead attached.

Comment 1 Jeremy Katz 2000-09-19 06:43:12 UTC
Created attachment 3460 [details]
take care of asking for double passwords during ftp install of rpms

Comment 2 Jeff Johnson 2000-09-26 22:30:53 UTC
(red face) Fixed in rpm-{4.1,4.0.1,3.0.7} cvs. Thanks very much for finding.


Note You need to log in before you can comment on or make changes to this bug.