Bug 176722 - kdevelop svn problem
kdevelop svn problem
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kdevelop (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-30 15:02 EST by Paul Filimon
Modified: 2008-12-02 10:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 10:55:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Filimon 2005-12-30 15:02:35 EST
Description of problem:

I want to use kdevelop with a svn repository but after I imported the project
and tryed to use "Subversion" panel from "File selector", I recived "kdevelop
said: "Unknown protocol 'svn+http'" even if I use 'svn://' protocol to connect
to repository.

Version-Release number of selected component (if applicable):

$ kdevelop --version
Qt: 3.3.3
KDE: 3.3.1-3.11 Red Hat
KDevelop: 3.1.1

$ svn --version
svn, version 1.2.1 (r15230)
   compiled Jul 13 2005, 05:23:17


Steps to Reproduce:
1. make a new directory and jump there
2. use svn to commit a repository
3. start kdevelop and use 'Import project' from 'Project' menu
4. use a menu from 'Subversion' pannel from 'File selector'
  
Actual results:

"Unknown protocol 'svn+http'" 

Expected results:

"Committed" or another svn output.
Comment 1 Paul Filimon 2005-12-30 15:10:16 EST
trace

$ kdevelop
kbuildsycoca running...
QLayout "unnamed" added to IndexView "unnamed", which already has a layout
QObject::connect: No such slot ClassViewPart::removeNamespace(const QString&)
QObject::connect:  (sender name:   'ClassViewWidget')
QObject::connect:  (receiver name: 'ClassViewPart')
QObject::connect: No such slot subversionPart::slotActionAdd()
QObject::connect:  (sender name:   'subversion_add')
QObject::connect:  (receiver name: 'Subversion')
QObject::connect: No such slot subversionPart::slotActionRemove()
QObject::connect:  (sender name:   'subversion_remove')
QObject::connect:  (receiver name: 'Subversion')
QObject::connect: No such slot subversionPart::slotActionAddToIgnoreList()
QObject::connect:  (sender name:   'subversion_ignore')
QObject::connect:  (receiver name: 'Subversion')
QObject::connect: No such slot subversionPart::slotActionRemoveFromIgnoreList()
QObject::connect:  (sender name:   'subversion_donot_ignore')
QObject::connect:  (receiver name: 'Subversion')
QObject::connect: No such slot subversionPart::slotStopButtonClicked(KDevPlugin*)
QObject::connect:  (sender name:   'unnamed')
QObject::connect:  (receiver name: 'Subversion')
ASSERT: "part && parent" in partwidget.cpp (41)
QObject::connect: No such slot subversionPart::slotAdd()
QObject::connect:  (sender name:   'unnamed')
QObject::connect:  (receiver name: 'Subversion')
QObject::connect: No such slot subversionPart::slotRemove()
QObject::connect:  (sender name:   'unnamed')
QObject::connect:  (receiver name: 'Subversion')
QObject::connect: No such slot subversionPart::slotAddToIgnoreList()
QObject::connect:  (sender name:   'unnamed')
QObject::connect:  (receiver name: 'Subversion')
QObject::connect: No such slot subversionPart::slotRemoveFromIgnoreList()
QObject::connect:  (sender name:   'unnamed')
QObject::connect:  (receiver name: 'Subversion')
Comment 2 Rick L Vinyard Jr 2006-07-28 21:27:23 EDT
Here's a temporary solution, and possibly a hint where the problem lies:

(1) Close kdevelop

(2) Copy /usr/share/services/ksvn+http.protocol to
/usr/share/services/svn+http.protocol

(3) Edit /usr/share/services/svn+http.protocol changing:
protocol=ksvn+http
to:
protocol=svn+http

(4) Restart kdevelop... subversion should work again
Comment 4 Phil Knirsch 2008-12-02 10:55:01 EST
After closer inspection by the engineer it turns out that the simple fix for the services file will not grant the new functionality as this is only available in newer versions of kdevelop and would require a feature backport.

As the inclusion criteria for Red Hat Enterprise Linux 4 Update 8 state that Software functionality enhancements are not in the focus for that update it this request will not be scheduled for this update.

Note You need to log in before you can comment on or make changes to this bug.