Bug 176723 - sound-juicer is totally broken.
sound-juicer is totally broken.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-30 16:15 EST by Dave Jones
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-09 15:20:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2005-12-30 16:15:45 EST
Start sound-juicer, insert CD, track listing comes up. Looks promising. But then..

Clicking buttons does nothing at all. Starting it from a command line reveals why..

(sound-juicer:25094): libglade-WARNING **: could not find widget creation function

(sound-juicer:25094): libglade-WARNING **: could not find widget creation function

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_destroy_signal'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_delete_event'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_play_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_reread_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_quit_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_seek_moved'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_genre_edit_changed'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'prefs_eject_toggled'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_previous_track_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_deselect_all_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_volume_changed'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_contents_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_artist_edit_changed'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'prefs_cdrom_changed_cb'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'prefs_strip_toggled'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'prefs_base_folder_changed'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_title_edit_changed'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_tracklist_row_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_extract_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_about_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'prefs_profile_changed'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_tracklist_row_selected'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_next_track_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_eject_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_seek_release'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'prefs_edit_profile_clicked'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_select_all_activate'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_edit_preferences_cb'.

(sound-juicer:25094): libglade-WARNING **: could not find signal handler
'on_seek_press'.
Comment 1 Dave Jones 2005-12-30 16:37:47 EST
I thought I'd try and build it myself and have a poke at it..
I'm puzzled how it even builds on rawhide right now..

during the configure..

checking for GSTREAMER... configure: error: GStreamer 0.8 not found
error: Bad exit status from /var/tmp/rpm-tmp.39960 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.39960 (%build)

(16:39:53:root@nwo:SPECS)# rpm -qa | grep -i gstreamer
gstreamer-0.8.11-2.1
gstreamer-plugins-0.8.11-1.1
gstreamer-devel-0.8.11-2.1
Comment 2 John (J5) Palmieri 2006-01-04 19:12:38 EST
Running /bin/gst-register-0.8 as root should fix it from bombing.  Also rm -rf
~/.gstreamer-0.8. (once we move to 0.10 gst-register will no longer be needed).
 I for the love of me can not figure out why upgrading gstreamer packages
sometimes fails to tun gst-register in the post.

As far as the libglade problems I haven't been able to figure it out since it
doesn't hit any other apps.  I will dig deeper.  
Comment 3 Dave Jones 2006-01-04 23:53:41 EST
blew away the dir & ran gst-register-0.8
no change in behaviour at all. still doesn't want to rip my xmas presents :-(
Comment 4 John (J5) Palmieri 2006-01-09 15:20:25 EST
And now it is totaly fixed. 2.13.1-4 fixes the issues with libglade being unable
to find the symbols.  A simple recompile with CFLAGS+="-Wl,--export-dynamic" did
the trick.

Note You need to log in before you can comment on or make changes to this bug.